I have a 27" screen which is connected to my mid-2012 MacBook Pro retina through a HDMI/DVI-D (HDMI on the MacBook Pro, DVI-D on the screen).

Before I was using a adapter DisplayPort+USB/DVI-D and I was able to get 60Hz refresh rate.

Now with the HDMI/DVI-D I have only 30Hz.

Is there any way to change (by forcing?) refresh rate to 60Hz?

Or is it a hardware limitation?

NOTE: I can't change the Refresh Rate value from System Prefs, the menu is disabled and the value is set to 30Hz.

EDIT: Here's the System Prefs window enter image description here

  • Did you check System > Monitors or Displays already? – Rob Mar 5 '14 at 9:48
  • Does it changing back to DisplayPort changes back to 60Hz? – Ruskes Mar 5 '14 at 10:02
  • 1
    Robuust: yes, but the select menu is disabled (can't set anything else but 30Hz) Buscar웃: yes, it changes back to 60Hz. – avetis.kazarian Mar 5 '14 at 10:31


You can use the freely available Terminal app cscreen to force display settings. The app is pretty self explanatory.

brew cask install cscreen
cscreen -h
Usage: cscreen [-d <depth>] [-x <width>] [-y <height>] [-r <refresh>] [-s <display>] [-v] [-m] [-f] [-l] [-h]
           [-d <depth>]    : specifies the bit depth (bits per pixel)
           [-x <width>]    : specifies the width in pixels
           [-y <height>]   : specifies the height in pixels
           [-r <refresh>]  : specifies the refresh rate in Hz
           [-s <display>]  : specifies which display to use (defaults to main display)
           use a as the option to -s to specify the action on all displays
           [-i <displayID>]: picks a display based on CGDirectDisplayID (permanent per display)
           continue to use '-s a' for "all displays"
           [-v]            : display valid modes (use -s to specify display or nothing for the default)
           [-m]            : require an exact match
           [-f]            : forces settings (ignores safety mechanisms; USE AT YOUR OWN RISK)
           [-l]            : lists the current displays and modes
           [-p]            : sets the requested display to have the menu bar
           [-h]            : displays the usage

           Note: Using -p will change the display index so you will likely want to use -l again to show the current
           displays if you wish to use -p a second time.
  • 12
    FYI, if you use homebrew, cscreen can be installed with brew cask install cscreen. – Brandon Fosdick Dec 19 '15 at 23:00
  • 3
    Just chiming in here, I tried this and didn't have any success on OSX 10.11. Bother monitors show refresh as 0, and when forcing configurations nothing seems to happen with the display. – Phil Ricketts Feb 9 '16 at 2:56
  • 1
    @BrandonFosdick the real mvp... – Itachi Sep 8 '18 at 2:46
  • 4
    This helped me fix my macbook suddenly no longer driving my 4k screen at 60 Hz and always recoginzing it as 30 Hz. I did a cscreen -d 32 -x 2560 -y 1440 -r 60 -s 2 then changed settings using OS X Display Preferences again and now it's back at 60 Hz. – Johannes Rudolph Jun 4 '20 at 7:10
  • 2
    Calling brew cask install is disabled! Please use brew install --cask cscreen instead. Also got an error saying "cscreen" is from an unidentified developer. So, I had to open Finder, go to /usr/local/Caskroom/cscreen/2012.09/cscreen, and Control + Click cscreen to get it to work. – dpott197 Jan 14 at 12:04

When you're on the new Macbook Pro (post 2017), and you connected your external display to the right side of your macbook, the refresh rate settings dropdown may be disabled. That is due to the limitations of the macbook: https://www.macrumors.com/2016/10/28/macbook-pro-tb3-reduced-pci-express-bandwidth/

The two ports on the right side of the machine have Thunderbolt 3 functionality but with reduced PCI Express bandwidth. For that reason, Apple recommends plugging higher-performance devices into the left-hand ports on that machine.

After you connect your external display from the left side of your Macbook you will see the refresh rates dropdown after you hold down options and click on scaled.

  • Hello, I'm not used to macs. What is options and what is scaled. Maybe a stupid question, sorry. – Lorenz Meyer Dec 1 '19 at 11:26
  • 1
    Oh, I found: options is the key written alt on it, and Scaled is the second option of Resolution. The problem is, this brings more options for resolution settings, but the frequency settings are still not shown. – Lorenz Meyer Dec 1 '19 at 11:40
  • @LorenzMeyer Make sure your monitor/external display offers high refresh rates, some lower end monitors don't have that option – mxdi9i7 Dec 6 '19 at 2:50
  • Thanks, I understand now: this shows two windows, one on each monitor, and each with the options applicable to that monitor. And yes, not all monitors have the choice for the refresh rates. – Lorenz Meyer Dec 6 '19 at 10:30
  • Wow, thank you for this! Couldn't figure this out on a brand new 16" macbook. – Elliot DeNolf Jul 23 '20 at 20:47

I can only change the refresh rate for the 4K TV connected to my MacBook Pro (15-inch, 2016, Big Sur) by following these steps:

  1. Open System Preferences, then click Displays.
  2. option+click the Scaled radio button.
  3. Click the "Show low resolution modes" checkbox.

If steps 1-3 are above are not completed, the refresh rates are not visible.

Display preferences

  • This did it for me. When I connected my external 4K display, it seemed choppy. After doing these steps, I found that it was set at 30Hz refresh rate. Set it to 60Hz and was relieved with the refresh rate. There was no problem with the Macbook, adapter, or monitor. Whew. – radj Jan 9 at 7:13
  • 2
    Even following that, I still can't see the refresh rate menu ;'( – avetis.kazarian Jan 11 at 19:01

I came here searching for the answer myself because I've done it before but I installed an update and lost the settings. csreen and switchresx can both set the resolution for you, but there's a limit in OSX that needs to be bypassed in order to accomplish this. Additionally with the latest versions of OSX there's some sort of "system file protection" that prevents you from patching the relevant file. First, you have to disable that file protection (which I think gets turned on after each update) and then you have to patch the relevant file in OSX. If I find the answer for the latest version then I'll come back here and update the answer but you should google something to the effect to osx (your version) pixel clock unlock patch. Once you patched the relevant files you should be able to use utilities like switchresx (which is what I use) to set custom resolutions. I've found a patch for one version of osx here: https://github.com/Floris497/mac-pixel-clock-patch good luck!


You should be able to change the refresh rate in System preferences- Monitor.

This is an example of my HDMI to HDMI connection.

enter image description here

You can try using the SwitchResX app to see if that will work.

FYI: Something is happening with Mavericks and external display (similar to yours) but I am not qualified to talk about what.

  • I can't change it from the System Prefs. The Refresh Rate menu is disabled. – avetis.kazarian Mar 5 '14 at 10:31
  • What does it say? does it show the correct monitor type in the above window? ie Sharp LCD? – Ruskes Mar 5 '14 at 10:40
  • I edited the question (put a screenshot). – avetis.kazarian Mar 5 '14 at 10:49
  • Your system is not correctly identifying the Monitor with HDMI cable, it should name it by its name in Optimized for:. Also Try changing the resolution to 1920x1200. – Ruskes Mar 5 '14 at 11:03
  • Then how can I fix that? I tried changing resolution, but still can't change value to anything else but 30Hz. – avetis.kazarian Mar 5 '14 at 11:23

If you are using a USB-C adapter (or any other adapter such as older thunderbolt), check to see if the adapter supports 60Hz. Had a similar issue with INSIGNIA Slim Profile 7-Port USB-C HUB, read the paper inside the adapter box and found that it supports 30Hz max only.

  • 1
    The OP is using a MBP 2012. USB-C hadn't been invented yet – Matthew Barclay Aug 27 '20 at 1:11

After much googling and trials, I have come to the conclusion that if your hardware (both computer/screen) doesn't support higher frequency, well, you can't force it.

As for my own case, it was the both not available (old MacBook Pro + Dell cheap 27" "fake 4K")

  • 5
    I actually believe this is a software issue. My monitor can be overclocked. My displayport interface has plenty of bandwidth for the higher refresh rates. The problem is Apple's restricted software drivers. Also, works fine in Windows. – Phil Ricketts Feb 9 '16 at 3:13
  • @avetis.kazarian What model is your Dell 27" and what makes you think it's "fake" 4K? – philfreo Sep 30 '16 at 15:28
  • 1
    I find it hard to believe my hardware can't drive this monitor at full resolution and 60 hz, since it has no problem doing so when it's rotated 90, 180, or 270 degrees - only when I have it in normal orientation does it drop down to 30 for some reason. – childofsoong Mar 27 '17 at 21:55
  • @childofsoong: thanks for the information, this might be helpful resolving this issue. – avetis.kazarian Mar 29 '17 at 6:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .