1

I have a Java 7 application which I turn into a MacOS App following the instructions on http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/packagingAppsForMac.html.

This is no longer working. The signing still works (I use a "Mac Developer" certificate) and codesign verification claims everything is fine. spctl on my machine or trying to run the application on someone else's machine however results in rejection. (spctl only says "rejected" no further information even on verbose 4)

I tried adding --deep and --force to the code signing, but this did not solve the problem.

I also tried additionally signing the JDK plugin inside the App, but it did not help.

How does the process on the Oracle page above have to be adapted to work on 10.9?

  • What precisely no longer works? Does the app work if the recipient opens it using finder contextual menu for open and ignore the gatekeeper warning. Could you list your exact command on how you code sign the app in question? – bmike May 2 '14 at 19:55
1

My certificate was of the wrong type. Turns out it has to be of type: "Developer ID Application: "

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .