I have a Mac mini Server with Mac OS X Server 10.6.8 (Snow Leopard), where I run a WebDAV Server for syncing my OmniFocus (Mac <> iPad). But I don't use the Web-Server itself (only WebDAV).

When I do a sync in OmniFocus from my iPad, I can see the following ERROR message in the apache2 error_log file:

[..14] [error] [client IP] no acceptable variant: /usr/share/httpd/error/HTTP_UNAUTHORIZED.html.var

OmniFocus has no problem and sync just works fine (debug logfiles show clearly that WebDAV works as intended and the client has the needed User permissions & rights). Only the Web-Server is making trouble.

I suppose that an ERROR message in my WebServer logfile means that something is not configured as it should be?!

I understand that it has something to do with 'Multi Language Custom Error Documents' which is on by Default and is dependant on several Apache Modules. But even after reading several Readme files and studying online Tutorials it is far beyond my understanding of how this works together.

My Mac mini Server is still not in productive mode and turned off most the time. I only turn it on to resolve this last remaining ERROR message.

What I tried so far:

• extensive Google search / even on SE sites
• read all possible (available) Apple Server manuals
• started reading the Apache Server manuals
• I spent several nights trying to fix the problem (fiddling with .conf files)
• I did reset to default settings for the Apache Server
• I talked with some hackers about 'Apache Modules' at the 30C3 Congress in Hamburg 
• Installed a 2nd Mac OS X Server on another Volume to recover default conf files/values

• Could someone please explain me the meaning of 'no acceptable variant' ?

• Why does this ERROR matter? What do I need to understand to fix this ERROR?

  • you show us the output, what is the input ?
    – Ruskes
    Commented Mar 4, 2014 at 9:49
  • Input is a sync in OmniFocus done on my iPad. Custom sync with WebDAV Server.
    – user71997
    Commented Mar 4, 2014 at 16:46
  • Yes, please do so (as long as it doesn't reveal private/personal information)
    – nohillside
    Commented Mar 4, 2014 at 18:59
  • I did a rewrite of the whole Question.
    – user71997
    Commented Apr 1, 2014 at 0:41

1 Answer 1


Inside the httpd.conf file there are the following lines of code:

AddLanguage de .de
AddLanguage en .en

# LanguagePriority allows you to give precedence to some languages
# in case of a tie during content negotiation.
# Just list the languages in decreasing order of preference. We have
# more or less alphabetized them here. You probably want to change this.
LanguagePriority en de

# ForceLanguagePriority allows you to serve a result page rather than
# MULTIPLE CHOICES (Prefer) [in case of a tie] or NOT ACCEPTABLE (Fallback)
# [in case no accepted languages matched the available variants]
ForceLanguagePriority Prefer Fallback

You should understand what it means and how you can alter its functions. Maybe you ask an Apache Server Guru ;)

  • IMHO it is the Fallback directive that causes the problem. How can I alter the code ForceLanguagePriority Prefer Fallback — can this line be edited that it has a different function?
    – user71997
    Commented Apr 1, 2014 at 4:01

You must log in to answer this question.