6

I have an Asus PB278 (WQHD 2560x1440) connected via HDMI cable + HDMI-Thunderbolt adaptor to my MacBookPro Late 2011.

Until the update to OSX 10.9.2, I was able to use full WQHD resolution on my external Monitor. Since the update, the highest resolution I can choose is 1080p. It seems that the Monitor driver is broken or simply wrong.

Monitor Settings

Also, in the system information, the monitor is listed as 1080p TV ?!+

System Information

Has anyone the same problem? I did not find an update for the monitor profile. Is this a fancy Mavericks bug?

I've zapped the PRAM but that did not change anything. In Monitor Settings, tried to "detect monitor" and listing all resolutions - to no avail. Thanks for you help

3

The problem is Mac OS X. It is limited (in software, in the drivers) to a certain pixel colour clock rate for the HDMI port. The hardware in the Mac is more than capable of driving your WQHD monitor at 2560 x 1440 etc., but you can't do it via HDMI as the operating system's interface to it is essentially crippled in software.

It'll work via the DisplayAdapter port, though. The downside is that the single Thunderbolt connection will be taken, and you won't be able to connect to your monitor and other gear at home.

| improve this answer | |
2

Alright, the puzzle is solved.

I bought a miniDisplayPort to DisplayPort Adapter cable and hooked it up to my PowerBookPro. Automagically I can select WQHD 2560x1440 in the monitor settings.

HDMI is said to be limited to 1920x1200 (Even though I had my WQHD monitor hooked up with HDMI under 10.9.1 without any problem.) 10.9.2 seems to be more strict.

| improve this answer | |
1

Looking at your Display profile it shows the ASUS as a Television.

Consequently, it is set to run at wrong settings.

Your mac will be using RGB instead of YCbCr mode.

Possible fix is on the Monitor site.

Change the input source on the monitor till your Mac shows it as a Monitor.

UPDATE: I turns out the external monitor problems is a wide spread issue with the 10.9.2 (in most cases not with 10.9.1), and you can report yours here.

| improve this answer | |
  • I've gone through the displays menu but don't see any way to get rid of the TV setting. Or would changing from HDMI to DisplayPort make any difference? I have my doubts... – rfLo Mar 5 '14 at 14:53
  • Changing the connector can do that, so go ahead try it. – Ruskes Mar 5 '14 at 15:08
1

I had the same issue on the same screen (but without the iOS update), and the mini displayport to displayport was the solution: http://smile.amazon.com/gp/product/B004CAGDUA/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Good luck.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .