4

I've setup one very simple rule that applies to messages from one sender... the rule works just like it should (most of the time).

Randomly, after I've restarted Mail the rule will be unchecked, so all of the new emails that were supposed to have been moved aren't. So I dutifully go i and check it back on when this happens, and drag the emails where they belong. this started when I up graded to Mavericks (a week or two after it was released). It has become very irritating by now, and I wanted to know if anybody else has had this problem and found a solution, or if somebody has a suggestion on what I could do to keep that rule checked off!

4
  • 1
    What kind of mail are you using? GMail? Custom domain? Microsoft Exchange?
    – Rob
    Commented Mar 3, 2014 at 15:38
  • I'm seeing the same - I have several rules, and they all get disabled for no obvious reason. Very annoying. Commented Mar 5, 2014 at 20:03
  • I'm using a gmail account.
    – Circle B
    Commented Mar 5, 2014 at 20:22
  • possible duplicate of Mavericks Mail will not save preferences
    – grg
    Commented May 3, 2014 at 17:11

1 Answer 1

2
+50

Sounds like your Mail preferences are not saved.

Try this (it is not same as using Disk Utility to repair permissions)

You can use the ACL tool on the Recovery HD to do this:

  1. Boot into the Recovery HD using ⌘R.
  2. Run resetpassword in Terminal (available from Utilities → Terminal).
  3. Select your account from the drop-down list.
  4. Click the Reset button for Reset Home Directory Permissions and ACLs.

Source: grgarside — https://apple.stackexchange.com/a/110346/

If you are not comfortable doing it above way, there is a application called OnyX that will do it for you (and much more).

repair ACL

5
  • I'll give that a try as soon as I get a chance...
    – Circle B
    Commented Apr 23, 2014 at 17:10
  • It seems to have worked!
    – Circle B
    Commented Apr 26, 2014 at 20:25
  • Problem with user permissions unfortunately Disk Utility doesn't (give the opportunity to) repair those.
    – llange
    Commented Apr 27, 2014 at 21:05
  • Please give attribution and use quote formatting when copying information from other answers.
    – grg
    Commented May 3, 2014 at 17:09
  • @grgarside sorry about that, was not intentional, will pay more attention in the future
    – Ruskes
    Commented May 3, 2014 at 18:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .