11

Last night my mid-2010 Mac Pro woke up and probably installed some update (Mavericks). After this, every time I boot, black screen with cursor appears instead of login window.

  • I've tried blindly enter password and log in but with no results.
  • Power button doesn't respond, I can't even sleep or shutdown the machine.
  • I've cleared NVRAM, but it doesn't help
  • Safe mode doesn't work (mac restarts before progressbar go to 100%)
  • Disk repair tool found some minor problem (invalid count of folders in some directory - one extra) - no results
  • I've reinstalled mavericks (In the Command+R menu during boot), still not working.

What else can I try?

I have some data in encrypted home folder, so I want to recover some of the files.

  • 1
    Have you tried a verbose boot? Press and hold Command V at startup. It’s the same as a normal boot, but it displays the log. If there is an issue at some point, you might be able to pinpoint it. – Édouard Mar 3 '14 at 12:33
  • There is only one issue: hfs: Removed 1 orphaned / unlinked files and 1 directories BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or drectory But I don't know if it points to real cause. – mtt Mar 3 '14 at 13:38
  • Googling for similar issues leads to several discussions. It would seem that wiping the disk and reinstalling (/ ! \ you’ll need to copy your data first!! or you’ll lose everything) solves the issue. – Édouard Mar 3 '14 at 14:49
  • I'm facing the exact same issue and wanted to check in if you found a solution – grebneke Mar 11 '14 at 14:02
  • Finally I solved the problem, but it's hard to say how. The cause was corruption of encrypted home folder (old FileVault), system was unable to mount sparsebundle file. I started system in single user mode and tried to mount home folder sparsebundle file several times, but it said there is some internal error. Finally I rebooted my mac and it started to work correctly. – mtt Mar 11 '14 at 14:08
4

Ok guys - I had the same issue with my 2008 iMac and Apple support just walked me through the fix...

  1. Shut the computer down by holding the power button for 10 seconds
  2. Restart the computer and press shift at the same time until you see the progress bar start moving
  3. Once you reach the point where your screen goes dark and you see the cursor, type the first letter of the username for your computer, then hit Tab, then type your password, then hit Enter.
  4. After a moment, you should see the spinning beach ball
  5. Your screen should then move on to something along the lines of "Completing OSX Installation" (I can't remember the exact wording). Let it finish. After that it should go to your normal desktop and the issue should be fixed. (If your screen goes pitch black during this process, hit the space bar. I thought it wasn't working, but the screen was just sleeping).

Apparently it's an issue with an automatic update that never quite got past the login screen.

Hope this helps!

  • Jibinma, you are a prince. Totally solved my problem. Unreal. Huge thanks. – user73244 Mar 16 '14 at 22:28
  • Awesome! Worked for me also. I have iMac '11 with Mavericks and got the same problem all of the sudden. You saved my Mac. – Maksim Apr 1 '14 at 3:12

You must log in to answer this question.

protected by Community Mar 18 '14 at 2:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .