7

I am currently having an issue with my mac.

  1. Turn on the mac
  2. The apple logo appears followed by the login screen. There are 2 logins, one is a guest login and the other is my login.
  3. When I choose guest I am able to login
  4. When I choose my login it shows the apple logo briefly and then a blank screen
  5. When I tap the touch pad the screen briefly flashes the login screen but remains black
  6. I can hear the volume indicators and when I press buttons I can hear sounds.

I have tried restarted several times but it does the same thing. I'll need some help finding the next steps to solve this black screen.

4

It happened to me too. I just typed my login password, assuming the login screen was there and I could not see it. That worked like a charm and I booted into my normal Desktop. After a reboot it did not occur again.

  • it just happened again; same solution worked. – Jurgen Vinju Mar 7 '17 at 10:42
4

I tried the PRAM many times and it didn't work. Thank you Reve. Your link solution was the one that worked. Dunno why your solution was down voted.

I am copy pasting the text:

In the three years of using my MacBook Air, I have never had any major problems with it. It was totally reliable, even after I accidentally spilled coffee on it. However, the update to macOS Sierra 10.12.2 ruined its streak, leaving me with a blank screen that only displayed the cursor.

I initially blamed the update for this, but after I saw no similar reports from other users I started doing some digging. As it turns out, this problem predates Sierra by a couple of years. Apple has not addressed it yet, but, don’t panic: it is pretty easy to fix it yourself.

It is not clear what exactly is causing macOS to act up after installing an update, but it rears its ugly head after powering on the Mac. You can try to reboot or reset the PRAM and SMC — the first things that Mac users can try when something isn’t working right — but that will not fix it.

So, here is what you need to do. First, you need to shut down your Mac, if it’s powered on. Pressing the power key for a couple of seconds will do the trick.

Next, you have to boot your Mac in single-user mode. That’s done by pressing the Command and S keys at the same time, right after pressing the power key. If you did it right, you should see a whole bunch of lines on the screen in what is a Terminal-like interface.

(I’ve seen someone recommend that you reset the PRAM three times before booting in the single-user mode. There is no harm in doing that. Hit the Command, Option, P and R keys at the same time, right after you power it on, and wait until you hear the startup chime for the third time before letting go. Then, quickly press the Command and S keys, to get you into the single-user mode.)

You then need to type the following commands:

/sbin/fsck -fy
/sbin/mount -uw /
rm -f /Library/Preferences/com.apple.loginwindow.plist
rm -f /var/db/.AppleUpgrade
reboot

You will have to press the Enter/Return key after each one. The fifth command restarts your Mac. It will show the login screen. That’s normal, even if you previously bypassed it. Type in your password and you’re back in business.

You may run into this problem even after macOS Sierra 10.12.2, but know that you will be able to apply this method again if that happens.

  • That last bit in Single User Mode saved my computer! Thanks :) – Emil Sep 29 '18 at 10:06
4

There is likely an issue with something specific to your profile. You can verify this by booting into safe mode:

Hold Shift while booting, it will take longer than usual, and eventually the startup screen will say safe mode. This disables a lot of things that run at startup on the system AND in your profile. If you can then get into your profile something that automatically starts is the issue. If not...

Boot the system from either the install DVD or by holding Command+R (for recovery mode). When you get into recovery mode, use disk utility to repair the disk then repair permissions. Then see if you can get into your profile.

If you have another Mac, put it into target disk mode and rename the preferences folder in ~/Library. Reboot and try to get in.

Failing that you may have to create a new user on the system and migrate your settings and file from the old one to the new one. You should be able to create a new account using the guest login and authenticating as your administrative user in the System Preferences -> Accounts control panel.

  • Thanks for your help man but I gave it to IT before I saw this and guess what they did. They deleted everything :( – TheLearner Mar 4 '14 at 19:00
  • 1
    remember, IT is just a bunch of guys who learned all this stuff before you did! – Steve Chambers Mar 6 '14 at 16:42
1

With FileVault 2 and the new boot system, you can have a lot more going on than just the old standard, black, grey, grey + Apple logo, blue screen sequence.

Apple has an updated KB article covering the steps:

For you, you'll want to power off the mac and use Verbose Mode to see where the log in process is hanging. Grab a pencil or better a camera to take a picture of the screen when it's stuck - the last few items on the screen will isolate the specific failure you are experiencing.

0

I had similar post-login issue on my MacBook Pro 17". After logging in, screen in quick succession would gray out top window (pdf file in Preview, as per previous session), show black horizontal bars across whole screen, then go completely black. Sometimes the little rotating icon would show (fixed location, like when you boot) but then disappear. Keyboard lights on. Repeatedly I tried resetting SMC, P-RAM and one other suggestion found on line—which was to press power button once (brings up shut down/restart window, invisible with the black screen but still functional, then 'S' (blind action, but selects Sleep option), then hold power key down to force shut down, wait 15 seconds, then restart—but all to no avail.

THE FIX: Fix was to be holding down Command key then rapidly tapping 'Q' immediately desktop appeared after login. This quit the top application, Preview, which was displaying a pdf downloaded from the CA DMV website, zooming in on which was the last thing I did before the issue first occurred.

I trashed the pdf file—and machine rebooted normally. Preview then worked normally, and machine shut down/restarted normally as well.

Issue therefore seemed related to zooming in on a pdf in Preview, or something amiss about the downloaded pdf itself.

-2

I experienced this problem and found this resent article that resolved the issue.
Click here for the link

This is the actual original article

  • 2
    Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – nohillside Dec 24 '16 at 15:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .