4

Hi I recently upgraded to 10.9.2 and I cannot write to NTFS anymore - in fact I cannot mount NTFS anymore unless I removed the the lines that allow me to write NTFS in the past in /etc/fstab...

I also tried NTFS-3G and it's the same result - the system won't mount my NTFS drive unless I reverse to the default system files or settings (which only allow me to read NTFS, without enabling the write feature).

Did Apple disable NTFS write? Why?

Also I tried Tuxera NTFS and it gives me this error message: enter image description here

2

I updated my guide - turns out the issue is that osxfuse is just needed with ntfs-3g - fuse4x has to be removed.

http://coolestguidesontheplanet.com/how-to-write-to-a-ntfs-drive-from-os-x-mavericks/

1

In my experience, using paragon NTFS drivers works perfectly.

  • no paragon NTFS doesn't work – aeroxy Mar 4 '14 at 0:50
0

I found a description on how to use NTFS-3G. According to this source updated March 2014, the package ntfs-3g is updated and you have to sym link the mount_ntfs file to a new destination, so if you have set up before and have updated your brew you may need to unlink a few dependencies and definitely link to the new destination mount_ntfs destination. Also on completion when a ntfs disk is mounted a new error is displayed but the disk still mounts and is read/writable.

http://coolestguidesontheplanet.com/how-to-write-to-a-ntfs-drive-from-os-x-mavericks/

I personally updated to 10.9.2 without problems with my NTFS drives. The only problem copying onto an NTFS Drive takes very long. I have installed in my system preferences OSXFUSE 2.6.2 and NTFS-3G 2010.10.2

Yogi

0

no paragon NTFS doesn't work either. The solution I had was:

In the terminal:

brew remove osxfuse
brew remove fuse4x
brew remove NTFS-3G
  • Then remove everything in /etc/fstab

  • Restart the computer

  • Install Tuxera

  • Plug in the hard-drive, get an error message

  • Eject the hard-drive

  • Restart the computer

  • Plug in the hard-drive, now it works!

I think 10.9.2 installs some additional files that removed the support for NTFS-3G. For now I am happy with using Tuxera - and if anyone finds out how to use NTFS-3G, please share!

  • But you can't sudo brew... – Thomas Ayoub Mar 4 '14 at 7:37
  • Sorry, I wrote this with my memory. You don't need sudo before the brew. Instead, if you have installed fuse4x you need to remove the files - so the command is sudo rf "location." – aeroxy Mar 4 '14 at 19:03
  • This doesn't work for me "sudo: brew: command not found" in fact i have tried all the solution on the net and nothing worked. Help please! – user79238 May 29 '14 at 0:21
  • You might have to install brew. What version is your OS X system? – aeroxy Jul 14 '14 at 2:48

You must log in to answer this question.

protected by Community May 29 '14 at 2:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .