3

I am attempting to use iTunes through a work proxy.

When loading iTunes, it prompts me to enter a username and password for the http and https proxy servers, but fails, saying the password was incorrect. The pattern is that, the dialog will appear, details entered, and it will then ask for the http or https details, then repeat again and again.

  • I have tried DOMAIN\username, like, NTADMIN\bob
  • My network account is not locked
  • Sometimes, after entering my username & password on the first few times, I'm able to see some album art start to load. So, on some instances, I'm getting through the proxy.
  • My password is definitely being entered correctly.... Yes, I'm sure, and yes it works.
  • Network Connectivity Tests show:
    • Network interfaces verified
    • Internet connection verified
    • Secure link to iTunes Store failed.
  • (Technical) I have deleted my keychain & even deleted all settings and installed.
  • (Technical) iTunes is one of the only applications that don't work with the proxy.
  • (Technical) I have managed to get it working if I specify my proxy as my local CNTLM application. But I don't want to set my Windows system level proxy to always go through that.

Is there a way to force iTunes to use a specific proxy, rather than use the Windows system one?

  • You're not alone... itunes use both the proxy and direct flow ! Look your firewall behind the proxy. Regards – user77799 May 9 '14 at 14:45
  • Why has Apple never allowed any other options, such as alternative proxy addresses? – bigbadmouse Dec 19 '18 at 10:27
1

Try CNTLM to convert your NTLM proxy to a local proxy without authentication. In this way iTunes is able to connect to the internet.

  • As advised in the comments, I've tried that approach. – Teh Hippo Jun 17 '14 at 23:12
0

This happens when your proxy is set to "Use automatic configuration script". In order to fix this:

  1. Open Internet Explorer / Edge
  2. Open the Internet Options (for IE: Gear wheel on the upper right, then Internet Options)
  3. Open the "Connections" Tab
  4. Click "LAN settings"
  5. Make sure that under "Proxy server" you have entered the proxy manually
  • some of us at work are not allowed to change that. – bigbadmouse Dec 19 '18 at 10:25
-2

the key here is to enter the socks address manually, worked for me! :)

  • 2
    Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info on how a user would enter the socks address manually. Also, you may want to read How to Answer for tips on providing answers here. – Monomeeth May 14 '18 at 9:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .