46

A site that I visit frequently used to be located at:

http://www.site.com/sub/dir

But now it's just located it:

http://www.site.com/sub

The problem is, I visited the original location so often that Safari suggests it as the Top Hit and autocompletes it, even though it no longer exists (it returns a 404). So I start typing http://www.site.com/sub... and Safari fills in the rest with the old URL that no longer works.

How can I remove the old URL so Safari no longer autocompletes it? I already went and found the URL in my history and deleted it, but it still suggests it as the Top Hit.

10 Answers 10

32
  1. Open Safari.
  2. From the “History” menu, choose “Show All History”.
    • keyboard shortcut: ⌘ Y
  3. In the Search field in the top right corner, enter the web site you want to remove.
  4. In the list of search results, click on the web site you want to remove.
    • To select multiple sites, hold the command ⌘ key while clicking on the sites you want to delete. Or, to select a range, hold the shift key, click the first item to delete, then click the last item to delete.
  5. Press the Delete key on your keyboard.
| improve this answer | |
  • 1
    This didn't work for me at first. It seems like either there was a significant reindexing delay (I also tried restarting Safari), or other results on the same domain (but not the same subdomain) influenced the suggestion. The auto-complete result finally disappeared after I scrolled through a ~10 day period and weeded out every page I saw for the domain. – abathur Oct 16 '18 at 15:00
  • That doesn't work if the site is in a bookmark. – Harper - Reinstate Monica May 18 at 17:37
6
  • Start by typing in the website into the Safari URL bar "example Gmail".

  • Then at the bottom of the suggestions it'll show you Search for 'gmail' in History.

  • Click that option and then select all and press delete.

Worked like a charm for me.

| improve this answer | |
4

deleting it from my bookmarks worked for me.

backstory: typing yah for yahoo.com autofilled yahooligans.com (safari 8.0.7 on yosemite 10.10.4).

fix: found it deep in a sub menu in the bookmarks folder and erased it. now typing yah fills yahoo.com. woo hoo and thanks!

| improve this answer | |
1

This is for OSX10.10.1 Yosemite

  1. In Finder, hold down "option" key and click on "Go"
  2. Select Library
  3. In Library, go to Safari
  4. In Safari, click on History.plist; this should open up "Pref Setter" App
  5. In the App, the History window should open.
  6. Type in the website you want to delete in the search field in top right.
  7. Delete the entry. I only deleted the actual String and not the Item.
  8. Save and close.
  9. Close Safari and re-open Safari.
| improve this answer | |
1

If you don't want to delete all your preferences and history and bookmarks, and instead only delete the saved url (as posed in the original question), then the following shortcut might be helpful:

  1. type the following to open safari: ⌘-space, safari, enter
  2. once safari is open/active, type this to enable searching of history: ⌘-y, ⌘-f
  3. start typing whatever url you wish to delete from your autocomplete, it will start filtering the displayed list.
  4. select entries to be removed: (shift + scroll); or just use the mouse.
  5. press the delete key
| improve this answer | |
0

Go into your history and delete all visits to the website. Alternatively, it may be easier to just delete all of your history instead.

| improve this answer | |
  • 1
    "I already went and found the URL in my history and deleted it, but it still suggests it as the Top Hit" ;-) – daGUY Feb 27 '14 at 14:25
0

To remove an address from the auto fill listing, click on the ! Mark at the end of the listing. The pop-up menu asking to "Create New Contact" or "Add to Existing Contact" can be scrolled down further to the option "Remove from Recents". This option will remove the address.

Why they hid this option is any bodies quess.

| improve this answer | |
0

Alright- I've figured it out. I'm not even remotely bright, but here is the problem:

The reason that autocomplete keeps filling in the websites and bringing it up as a "top hit" and suggesting things is because you have a link to that site saved in your bookmark folder.

Step 1: Delete all the sites from your bookmark folder that you do not want to show up in autocomplete.

Step 2: Clear all history, restart Safari, and Voilà - Autocomplete shows nothing.

| improve this answer | |
-2

Go to Settings -> Autofill -> Other Forms, Tap Edit and remove your site and restart browser. It helped me.

| improve this answer | |
-2

Preferences > Search > smart search field: manage websites

| improve this answer | |
  • That's for searching the website directly from the smart search field; has nothing to do with autocomplete. – daGUY Feb 18 '15 at 23:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .