2

I'm trying to connect to VPN on Mac OS X via several ways:

  1. Native vpn client (doing something like this: https://www.publicvpn.com/support/MacOSX105.php)
  2. By Anyconnect vpn client
  3. By Cisco vpn client

In 3 case I receive the 51 error and I read, that it's ok for mac. In 1 case I recieve no errors, just can't connect. In case 2 I receive error message: "the vpn server did not respond", but ping to vpn server I try to connect is successfull.

What I'm doing wrong? When I tried to connect in Windows by cisco vpn client, connection was successfull. Can the problem be in that the vpn is based on windows?

  • Please consider a better formatting. It's difficult to read. A quick search on Google turned up this: anders.com/cms/192/CiscoVPN/… Also, it's never just okay to receive an error. – Shane Hsu Feb 26 '14 at 15:29
  • Very sorry for formatting, I've copied my question from another site and didn't notice this trouble (( I tried to do like in link, and received this responce: /System/Library/Extensions/CiscoVPN.kext failed to load - (libkern/kext) requested architecture/executable not found; check the system/kernel logs for errors or try kextutil(8). – Mary Ryllo Feb 26 '14 at 15:48
  • What version of the Cisco VPN client are you trying to use, what version of the Mac OS are you running and what model of computer are you running it on? – Édouard Feb 26 '14 at 15:54
  • Cisco vpn client: 4.9, Mac OS: OS X 10.8.5, Computer: Macbook Air – Mary Ryllo Feb 26 '14 at 16:07
  • Is the VPN accessible to anybody else? Can any other devices in your network connect to the VPN? – samh Aug 31 '16 at 11:09
1

The Cisco VPNClient app is not officially supported in 10.8. You may have some luck by using Java Preferences to specify the 32-bit JVM and either disabling the 64-bit or changing it to be secondary.

You're better off replicating the settings from your Cisco configuration into a new native VPN (IPSec) connection.

Look for the encrypted Group password in your .pcf file, then head over here to get the decrypted value. After that it should be fairly obvious.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .