1

How can I disable password autofill/autosave in Google Chrome without deleting all my passwords from the Keychain? I tried just disabling autofill, but Chrome keeps filling out passwords and still conflicts with LastPass.

I want to keep the passwords in the Keychain to use them on my iPhone/iPad with iCloud Keychain, but in Chrome I only want to use LastPass. Using Lastpass and Chrome autofill together does not really work properly, since they seem to conflict. I have to try multiple times to fill out login data etc.

Any help is much appreciated. Or should I file a bugreport with Chrome?

3

In Chrome, open the Preferences

scroll down and use Advanced

Find Passwords and Forms and un-check it.

enter image description here

To prevent Chrome using already stored passwords remove it in keyhain.

You have to do that for every Chrome password saved in keychain :(

enter image description here

  • As I said, this does not prevent chrome from filling out previously saved passwords (at least for me). Did you try it? – tholu Feb 26 '14 at 10:04
  • Maybe I did not understand your question? you want to keep the Chrome passwords in keychain but you do not want Chrome to use them? – Ruskes Feb 26 '14 at 10:18
  • Exactly, but Chrome seems to use it anyway even if Autofill is disabled. – tholu Feb 26 '14 at 10:19
  • see my update :) – Ruskes Feb 26 '14 at 10:31
  • 1
    Thanks, while waiting are you interested in Apple script to do that for you (disable Google Chrome access to keychain)? We would have to find one first, or ask a new question here. – Ruskes Feb 26 '14 at 11:10
1

Open Safari. Click Preferences on the top left next to the Apple logo. A box appears. You can now see Autofill on top. Click Autofill. Now select or unselect as per your requirements.

  • Thanks for taking the time to answer. But this is how to deal with password autofill in Safari; tholu was asking about Chrome. – Alistair McMillan Oct 27 '14 at 18:43
0

In a similar vein to Buscar's solution. A way of getting chrome to forget already entered passwords and usernames is to clear browser history. Chrome -> Clear Browsing Data -> Make sure the passwords checkbox is selected and that "Obliterate the following items from:" is set sufficiently far back.

0

This is working with my Google Chrome.

Just go into History in Chrome or Press Ctrl+H and clear your history. Obliterate the following items from the beginning of time. Then uncheck the password check button and hit clear browsing data.

Please Check this

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .