The volume on my macbook pro has suddenly become greyed out. I haven't installed any updates or made any modifications to the computer, it just suddenly became greyed out after waking the macbook up from sleeping.

I've tried resetting the PRAM, but I don't hear any chime at all when I start up my computer, no matter how long I wait/how many times the computer re-restarts itself.

There also seem to be no internal speakers detected when I go into system preferences. For both input and output the computer detects 0 devices.

Thanks so much in advance for any help!!

  • Does the headphones jack works? also try reseting the SMC.
    – Ruskes
    Commented Feb 26, 2014 at 10:35

8 Answers 8


Try switching back to your internal speakers with [alt]-clicking on the speaker icon in menubar. Many interfaces don't support volume adjustment and thus the control becomes greyed out.

enter image description here

  • Thanks it solves my problem. I had to switch from M2232 to Internal Speakers.
    – Szu
    Commented Oct 22, 2014 at 8:42

The switch in the headphone input could be stuck, you can put in a headphone jack and wiggle it around. Don't be afraid to use a little force, just don't break of the plug. I had this problem too and this solved it for me at least.

  • 2
    ugh, this did solve it.
    – H2CO3
    Commented Nov 5, 2015 at 18:54

I just had this same problem. I didn't realise straight away but it must have happened after taking out my headphones. I accidentally solved it by doing the following:

  1. Make sure your headphones are plugged in and sound is working.
  2. Alt-click the speaker icon at the top of the screen, then click on 'Sound Preferences'.
  3. On the sound preferences screen, unplug your headphones.

Try picking up some compressed air and using it to blow out any dust or debris that might be in the headphone jack. Make sure to first expel any liquid build (white frost-like substance) before you spray in the headphone jack.
You can also try fishing around in there (gently) with a ridiculously small flathead screwdriver.
One question for you, is there a red light coming out of the headphone jack? That's usually a bad sign that the audio jack thinks there's an optical audio device plugged in (permanently.) If you're MacBook is under warranty the Genius Bar will replace the Main Logic Board for free (or about $300 if it is Out of Warranty.)
Otherwise, the simple and inexpensive Griffin iMic will provide USB audio input & output.


I had no output from speakers, or headphones. And the System Preferences - Volume was greyed out.

I tried everything up to including a PRAM reset and nothing worked.

Took it to the company tech and after awhile he figured out what was wrong.

The inner head phone jack was dirty. He cleaned it with a qtip or a special computer cleaning device. Apparently there’s a internal sensor in the jack that will prevent the internal output from functioning if it’s to dirty. It’s not like a dropped the computer in a dirty pond. I would have never figured that out.

Anyways, that’s what fixed it for me with the same symptoms as listed.


I just blew into the headphone jack - problem solved!

  • This works until you plug and unplug your headset
    – lomse
    Commented Apr 16, 2015 at 1:19

I had this same problem with my MacBook Pro, and used the technique described by dennismuys. I inserted and removed my headphone plug about a dozen times, and the internal speakers started working again. I have no idea what could possibly have gotten in the jack to keep the switch from closing. Lint maybe.

  • Welcome to Ask Different! Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful.
    – grg
    Commented Aug 14, 2014 at 19:38

I have had the same problem twice. And what I did was (for the first time[i am listing two so there are more possibilities]) 1st. restart my laptop. I know that it sounds cliche. But it works most of the time. 2nd. If all else fails. Try playing with the volume buttons on the keyboard. And this one sounds silly but it helps. Try the second one and then restart your laptop. That is what I did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .