2

1/After I updated to 10.9.2 this morning, my OSX keeps crashing over and over again. Up to now is almost 10 times or more. 2/Besides that issue, I also found my Contextual Menu in Finder really weird. It's messy and lost "Services" menu item. (see image below)

Contextual Menu

I doubt that some of my Apple Scripts may be incompatible with 10.9.2 and caused such crash. Can anybody guide me how and where to remove those add-on scripts? 3/ Also when I press any keys from the Hot Keys section above on the keyboard, it caused OSX to crash. Does anybody know how to fix the crashing?

  • About Contextual Menu, I can't help you, but the crash occurred by using the hot-keys, it's probably because you're using NoEjectDelay. The dev is aware and is trying to fix it. Until then, just use the uninstaller found on the page. EDIT (27/02/2014): A new version has been released and it's working. Try it out. – vallovic Feb 26 '14 at 12:13
  • Are you running any third party utilities to extend or alter the Finder? A few proposed answers are suggesting you have Total Finder installed. – Graham Miln Feb 27 '14 at 11:04
2

It is very probably caused by Total Finder app. Try to update it or simply quit it and run again. It worked for me and contextual menu is back.

  • Install the new TotalFinder, it fixes all the bugs. – user71569 Feb 27 '14 at 2:16
  • Do you believe the questioner has TotalFinder installed? Did you also experience this problem after upgrading? – Graham Miln Feb 27 '14 at 8:16
  • Updating to the latest TotalFinder Version helped me to solve the issue. The Problem with the missing context menu entries appeared only in TotalFinder and not in the normal Finder Window. Thank you! – user71607 Feb 27 '14 at 10:17
-1

Repair your disc permissions after update might help. I updated last night and shut down for college this morning. Upon booting I have a grey screen with a flashing question mark folder. I've tried all the reset tricks the mac simply can't 'see' the hard drive. My directory is corrupted. I cant pin it to the update. I've done some tests and found my hard to be fine. But my mac cant read/ power of ANY internal hard drive! Any hard drive I put it won't spin up. external is ok but annoying since I have a 2.0 enclosure. I can only surmise the hard drive cable is faulty. It had to happen 2 days before a project in college is due. My mac is only a year and half old and only a few months out of warranty. Thanks apple. Thanks a lot.

  • As you can see, it's a bug in Total Finder that the developer has patched. – bmike Mar 6 '14 at 23:00

You must log in to answer this question.

protected by Community Mar 6 '14 at 23:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .