8

I would like to set up Boot Camp with Windows 7 on OS X Mavericks 10.9.2. I am using the new Mac Pro (MacPro6,1), in case that is relevant. (Perhaps the PCIe flash drive is just not capable for whatever reason.)

When I point Boot Camp at a Windows 7 ISO, I get this dialog, of course:

Your bootable USB drive could not be created
Boot Camp only supports Windows 8 installation on this platform. Please use an ISO file for Windows 8 installation.

I'd love to know if anyone has any hacks to lower the minimum required version to Windows 7. Most of the posts I see talking about Boot Camp and Mavericks say that the wizard offers you Windows 7. I assume, then, that this change has happened in one of the updates since Mavericks was first released (or a bunch of people hastily updated their Lion/Mountain Lion blogs with Mavericks / 10.9 just for Google juice).

Oh, how I would love to follow the dialog's advice, and "use an ISO file for Windows 8 installation." That's only half sarcastic; I hate Windows 8 with a passion, but I honestly did try to make it work, and couldn't (see below). Still I am more interested in getting Boot Camp to allow me to install Windows 7, because that's what I'm really trying to do. Of course any suggestions for bypassing the below problems will be appreciated as well.

I've seen other posts where they explain how to get the bootable USB drive working by editing the minimum machine required in Boot Camp's info.plist, but I couldn't find anything in that file to mess with to lower the minimum Windows version supported - that all seemed to be about hardware requirements. I actually have had absolutely no problems creating a bootable USB drive for Boot Camp (once I realized that Windows requires about 40 more bytes than typically found on a 4GB thumb drive), or getting Boot Camp to offer me the option to use a bootable USB drive. Now I just want Boot Camp to allow me to use Windows 7.


Background: Why Windows 8 isn't working for me

I was actually trying to get Windows 8.1 and Windows Server 2012 R2 to work, but encountered errors in all attempts. For 8.1 I received the following error message well into setup and long after the BOOTCAMP drive was formatted (evidence: exhibit A):

Windows installation encountered an unexpected error. Verify that the installation sources are accessible, and restart the installation.

Error code: 0xC0000005

For Windows Server 2012 R2 I got this error message after formatting the BOOTCAMP partition but before hitting Next (evidence: exhibit B):

We couldn't create a new partition or locate an existing one. For more information, see the Setup log files.

I looked at this Apple KB article, but it's a joke. The "answer" is to format my USB drive using FAT. So that Boot Camp Assistant can immediately format it all over again. Genius.

I then tried the instructions listed here, which sounded quasi-promising:

http://forums.macrumors.com/showthread.php?t=1671442

But this made things even worse. I ended up with the following error message upon choosing the BOOTCAMP partition and clicking Next (I forgot to take a picture of my monitor here, sorry):

Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed on GPT disks.

I tried all of these techniques multiple times with ISOs from MSDN; and even re-downloaded all of the ISOs in case any of them were damaged along the way. To further prove to myself that the ISOs were not the problem, I created stand-alone VMs using each one in Parallels, and they were created without issue.


Really, though. I just want Boot Camp to let me use Windows 7. Really.

  • The shot shows several drives - I think you need to be clear which ones they are and how you have partitioned them – Mark Feb 26 '14 at 2:18
  • @Mark, the drive that I am trying to install Windows on is the one that is selected (Drive 4 Partition 4). This drive was created using Boot Camp Assistant (the little UI thing where you drag the slider to divide your drive between Mac OS and Windows). Drive 6 is an external SSD, and absolutely not where I am trying to install anything (why the Windows dialog shows that as sort-of-selected, I don't know). – Aaron Bertrand Feb 26 '14 at 2:20
1

This one:

Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed on GPT disks.

Can be worked around like this:

Using the Bootcamp assistant, revert the HD to a single OSX partition layout. Then use the Disk utility to shrink the OSX parition, leaving "free space" for the planned Windows installation.

Then, boot from yor Windows USB stick ("EFI boot") and select the free space as target for the installation.

This worked for me.

Regarding Windows 7:
I don't know. I'd like to install Windows 7 as well...

0

So I discovered a couple of things:

  1. Windows 7 simply isn't supported under Boot Camp on the new Mac Pro (see the Mac Pro table here). I suspect this may be related to drivers - perhaps the PCIe or GPUs? So I don't think there's any way to "trick" Boot Camp into doing it (initially I just suspected that Microsoft may have paid Apple to raise the support floor to get Win8 numbers up, and that the restriction was artificial).

  2. One of the errors I received, We couldn't create a new partition or locate an existing one, was due specifically to having a Thunderbolt device connected. Once I disconnected that I could get a little further, but still am not able to fully install Windows. The error I get now is Windows could not update the computer's boot configuration. Installation cannot proceed.

enter image description here

Support is useless.

  • Apple support: "Oh, Windows installer can start? Call Microsoft; at that point it becomes their problem."
  • Microsoft support: "Oh, this is a Mac? Call Apple; we can't help you fix problems with their software/hardware."

Wonder who Apple would tell me to call if my problem was installing Mac OS under Boot Camp? Hmmm, maybe I should try that...

Guess I will have to bring it in. Wonder if any of the geniuses have set up Boot Camp on this machine yet...

  • what did u do with ur errors ? >> about Windows could not update the computer's boot configuration. Installation cannot proceed. – user110717 Jan 22 '15 at 22:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .