0

We recently upgraded several of our Macs to Mavericks. On one in particular, I'm seeing unexpected behavior when logging in to a Windows fileserver.

From Finder, I hit cmd-k, then enter smb:\\servername01\

The Finder immediately logs into the server without asking for a username or password. All fileshares on the server are visible but inaccessible. Login name is GUEST (all caps). To fix, I have to eject the fileserver and then log in using smb:\\username@servername01\. OS X then prompts for my Windows domain password as expected.

I have deleted my login keychain and deleted all relevant passwords from the system keychain. The behavior is reproduced in other accounts. However, all other Mavericks computers don't have this problem. I also have deleted related preference files (com.apple.finder comes to mind). Is there anywhere else that this setting could be stored?

1

The two places that come immediately to mind are the favorites section of Go to Server... so you might clear that out. Secondly, look in the Login Items pane of Users & Groups preference pane.

Also, if more than one user logs in to the Mac, be sure to eject the share before fast user switching (or logging out all users but one) to prevent their mount from controlling the access.

Apple is in the process of switching from AFP to SMB2 as the default share - so perhaps some changes there are not completely done or documented.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .