My dad1 recently switched to Mavericks. With it came the loss of calendar synchronisation with his iPhone through iTunes.

I thus added his iCloud account to his Internet Accounts system preference pane for it to sync.

Here is how I proceeded to the best of my recollection:

  • Quit Calendar.app
  • Launched System Preferences.app and went to the Internet Accounts pref pane
  • Added his iCloud account to the list
  • Quit System Preferences.app
  • Launched Calendar.app again

Calendar.app then displayed a dialog saying it was syncing. For hours, perhaps even days. It still does so every time it is launched, rendering the app unusable. Right now, he makes do with his phone but it’s an uncomfortable situation.

Calendar stuck on sync

The message reads (approximate translation):

Moving calendars to the

(yep, nothing after the “the”).

I tried removing the account from the System Preferences and moving ~/Library/Calendars out of ~/Library/ but to no avail.

Any other suggestion?

  1. Unfortunately, this means I don’t have first-hand access to his computer.
  • Is the calendar visible in icloud.com ?
    – Rob
    Feb 25, 2014 at 13:12
  • @Robuust Fifteen calendars do show up on iCloud.com
    – Édouard
    Feb 25, 2014 at 16:57

1 Answer 1


Uncheck the calendar in system preferences -> Accounts (or delete the whole account, I don't think it makes a difference).

Then delete files associated with the Calendar ~/Library/Calendars ~/Library/Caches ~/Library/SavedApplicationState/com.apple.iCal.savedState

Reboot Open calendar, check if it opens normally. If it does, quit calendar, add the account (or tick for calendar syncing) again, and reopen calendar.

Perhaps use something like Remote Desktop, VNC or TeamViewer if you don't have physical access to the computer.

  • And now I feel like an idiot. I’m pretty sure I did delete the account, but did it go through? Was Calendar.app running while I was doing it? In any case, Calendar sync was still on. Turning it off did the trick.
    – Édouard
    Mar 4, 2014 at 14:58
  • Sweet. This answer made my day.
    – thomax
    Mar 4, 2016 at 14:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .