I just got a new 2nd-generation iPod Touch 16GB. I believe I had a 2nd gen iPod Touch 8GB before.. but back when I did if I played a song, the album art would show up for that song on my locked screen. However this new iPod Touch doesn't do that (it just shows the default wallpaper I chose) and I can't seem to find the settings I need for it. Not looking for a jail-breaking solution by the way. Thanks.

2 Answers 2


Have you tried:

  • Select your iPod under the Devices section in the iTunes Source pane.
  • Select the Music tab of the iPod settings. The iPod settings are displayed to the right in the main iTunes window.
  • Select the "Display album artwork on your iPod" checkbox.
  • Click Apply to save the changes. The iPod begins to update as soon as Apply is clicked.
  • Is that exclusive to the iPodTouch? I don't see that option when I connect my iPhone 4 to iTunes.
    – John
    Apr 18, 2011 at 3:11
  • I thought it applied to both, the other thing I would think is the album art cache is corrupted, you can remove iTunes\Album Artwork\Cache while itunes isnt running, and see if that helps. Apr 18, 2011 at 11:54

I had the same problem with my ipod touch. I spent roughly 5 hours getting album art for all my music and even selected art for the video game tracks. It would even display on the ipod but just not when it was locked and that bugged me. From browsing google I found a simple solution: Simply power off your ipod and then reboot it. When it comes back on the problem should be solved, that's what worked for me.

  • What did you do during the 5 hours to fix things?
    – bmike
    Nov 14, 2012 at 22:34

You must log in to answer this question.