A while back, I installed Windows 8 on my MacBook Air (mid 2013 model) using Bootcamp. It never really worked, (it would freeze all the time, the WiFi would cut in and out, etc.) so I got rid of it. I tried to do this through Bootcamp again, but for whatever reason this didn't work, so I booted up on a live Ubuntu USB and manually erased the NTFS partition for Windows.

Once back in OS X (Mavericks, but it was Mountain Lion when I installed Windows), I expended the default HFS+ partition to fill the full space of the SSD. So now I've got a nearly out-of-box Macintosh HD partition; everything on the Mac side works fine.

But lately, I find myself getting increasingly annoyed at the BSD coreutils among other things, and so I'd like to be able to dual boot into some version of Linux (probably Ubuntu or Xubuntu, but this is kind of arbitrary).

My Issue

So but it turns out that when I "uninstalled" the Windows partition, something didn't quite update in the boot loader (I'm kind of fuzzy on my knowledge of the difference between a boot loader and a boot manager, so I might be using these terms incorrectly). When I start up my Mac holding down option, I get the following...

boot loader with two weird "Windows" icons

which is weird because this is what my main hard drive looks like in Disk Utility

disk utility with one partition

and again with gpt:

$ sudo gpt -r show /dev/disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  489562928      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  489972568     262151
  490234719         32         Sec GPT table
  490234751          1         Sec GPT header

To Be Fixed

I can't see where these icons would be coming from. In the end, I'd like to just have both of these gone (and I guess any other hidden remnants of Windows that they might be indicating).

  • Did you run the bootcamp utility to make a new partition?
    – Rob
    Commented Feb 25, 2014 at 6:31
  • When I originally installed Windows, yes. I tried to also use Bootcamp to remove the Windows partition, but this didn't work (and I can't remember why, unfortunately.) All I know is that I forcibly removed the NTFS partition because Bootcamp wouldn't let me.
    – jez
    Commented Feb 25, 2014 at 6:36
  • I also have no intention of making a new partition yet. I want to get rid of the icons before messing around with Linux.
    – jez
    Commented Feb 25, 2014 at 6:37
  • Can you try creating a new partition via the Bootcamp utility? You should also be able to remove it via that tool. It might remove one of the ghost Windows images on your disk.
    – Rob
    Commented Feb 25, 2014 at 7:27
  • The only options I have on Bootcamp are to a) create a Windows install disk, b) download apple support software, and c) install Windows. I do not want to mess around with installing Windows again. Been there, done that.
    – jez
    Commented Feb 25, 2014 at 7:35

4 Answers 4


When you don't use the Boot Camp utility to remove Windows, the Windows boot image on your EFI partition is not removed. This is what you see when you hold down during boot.

The procedure to solve this is not for the faint of heart. You need to mount the EFI partition in OS X (normally, it only gets mounted for system updates).

Mounting the EFI partition

List the partitions on your Mac:

diskutil list

You should see something like this:

 #: TYPE                     NAME          SIZE       IDENTIFIER
 0: GUID_partition_scheme                  *251.0 GB  disk0
 1: EFI                                    209.7 MB   disk0s1
 2: Apple_HFS                Macintosh HD  250.1 GB   disk0s2
 3: Apple_Boot               Recovery HD   650.0 MB   disk0s3

Take note of the numbers in /dev/disk0 and 1: EFI. Now mount the EFI partition (replace the numbers 0 and 1 if they are different in your output):

sudo mkdir /Volumes/efi
sudo mount -t msdos /dev/disk0s1 /Volumes/efi

Remove the Windows boot image

Now navigate to /Volumes/efi/EFI. This directory is supposed to only contain an APPLE directory. On a machine where I had Windows installed, it also contained a Microsoft and Boot directory. These can be safely removed, but for extra safety I would recommend renaming them to something different instead.

Then umount and delete the directory you created earlier.

sudo unmount /Volumes/efi
  • 2
    I had to use 'diskutil unmount /Volumes/efi' after that, the efi-folder was already gone. Thank you very much, it worked! even 5 1/2 years later
    – Malte
    Commented Jul 7, 2021 at 7:57
  • 2
    This worked for me (macOS 10.14 Mojave), I only had to use diskutil unmount /Volumes/efi instead of umount which told me “Resource busy”. diskutil unmount seems to also delete the directory directly unlike umount.
    – Melebius
    Commented Oct 29, 2022 at 6:10
  • Also make sure to choose the correct startup disk afterwards in Settings → Startup Disk. Otherwise the Mac tries to start from the (non-existent) Windows EFI files, and a flashing question mark will appear. To start the computer in this state, the option key has to be held down while booting, which will allow you to select the macOS partition.
    – SomeDude
    Commented Nov 13, 2022 at 9:51

Reinstall Windows again using BootCamp, then remove it properly using BootCamp Assistant. It takes time, but solves the problem. Dummy Windows entries are gone forever.


Deleting the Windows EFI Boot Entry

This is the most accurate and I have succeeded!

First, you’ll need to locate the EFI partition, which is where your Mac stores information about what operating systems can be booted from your Mac. In the Terminal, type this command:

diskutil list

You’re looking for a partition on your main hard drive called EFI.

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.1 GB   disk0s2

Once you find it, enter these commands one at a time:

sudo mkdir /Volumes/EFI

Next typing:

sudo mount -t msdos /dev/disk0s1 /Volumes/EFI

Replace /dev/disk0s1 with the correct partition you located using diskutil.

Typing Terminal:

cd /Volumes/EFI/EFI

Continue typing Terminal:


At this point the list may appear as Apple, Boot, Microsoft. Delete the Windows EFI Boot entry by typing this into the Terminal:

 rm -rf Microsoft
 rm -rf Boot

And unmount EFI, typing Terminal:

sudo umount /Volumes/efi

MacOS High Sierra can type is:

sudo diskutil umount /Volumes/efi

Restart your MAC and done!!!!

  • I don't have Microsoft in the folder only Apple and Boot.
    – Jules
    Commented Mar 5, 2020 at 18:58
  • 1
    Ah deleting boot fixed this for me
    – Jules
    Commented Mar 5, 2020 at 19:12
  • This is works, Windows option was gone from boot loader. But, I still get "do not enter sign" 🚫 when booting. I must press Option, and choose Macintosh HD each boot.
    – mul14
    Commented Nov 10, 2020 at 10:13

In the end, I gave up on actually removing the entries from wherever they're stored on the bootloader. Instead, I just installed rEFInd and manually removed the entries from the bootloader. I chose to go this route because after installing Xubuntu, this was the only way that my mac could find the xubuntu bootup file and also rEFInd has a feature where you can specify which entries you want to display and which you don't.

It's not entirely fixed, but I'll only have the laptop for a little while longer, and I can deal with it until then. Worse things have happened.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .