I have an early 2013 Retina MacBook Pro and I'm absolutely fed up with iTunes loading. I never use it and I never will.

As far as I can tell I've tried every suggestion to stop it from loading of it's own accord. The most common suggestion is to remove the iTunes Helper from my accounts Login Items which I have done ... repeatedly. It always worms it's way back in somehow.

How can I disable this app permanently? I simply don't want it to ever run ... ever. Only if I launch it manually.

  • When does it auto-load? Does anything cause it to startup or is it just happening when you log in? Feb 25, 2014 at 3:18
  • I'm honestly not entirely sure Mike. I'll keep an eye on it. I don't connect and iPods to the machine but I do have a UE Boom. I wonder if it could be that?
    – Jammer
    Feb 25, 2014 at 7:44
  • It's helpful to note what version of MacOS, and of iTunes. They keep changing the behavior between versions.
    – smci
    Oct 9, 2018 at 0:58

5 Answers 5


Short question, many solutions

The easy way

Using the Terminal, unregister all the links from you file types to iTunes /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -u /Applications/iTunes.app

If you still have trouble and iTunes opens automatically, check out RCDefaultApp. Old, but still working (right click->open...) http://www.rubicode.com/Software/Bundles.html#RCDefaultApp

Install, go to system preferences, disable all the "media" links to iTunes

"Quick and dirty" (Teminal)

First, do

sudo chown -R $USER /Applications/iTunes.app
chmod ugo-x /Applications/iTunes.app/Contents/MacOS

This will prevent iTunes from starting EVER. To start iTunes manually, do

chmod ugo+x /Applications/iTunes.app/Contents/MacOS/iTunes; open /Applications/iTunes.app; chmod ugo-x /Applications/iTunes.app/Contents/MacOS/iTunes

The way for the brave

Use duti, http://duti.org/documentation.html. Install using "brew install duti", make sure to have homebrew installed first (http://brew.sh). Remove all links to iTunes. Make sure to read Change file association in terminal? to get all current file types.

  • 1
    The sudo chown commands are now giving me Operation not permitted. Has perhaps something changed in MacOS/OSX?
    – Stan James
    Apr 8, 2019 at 15:20
  • 1
    @StanJames yes, System Integrity Protection aka SIP, added in El Capitan. support.apple.com/en-us/HT204899
    – Matt Ball
    Nov 26, 2020 at 2:52

I have the same problem with my MacBookPro. It is definitely lined to UE Boom. Everytime UE Boom makes a Bluetooth connection, iTunes starts. Logitech support was not help.

  • Yeah, same here ... insanely annoying.
    – Jammer
    Jun 24, 2014 at 12:59
  • Excellent information that it could be a bluetooth device connecting and initiating the playback.
    – bmike
    Jun 24, 2014 at 13:41
  • With a UE Boom pairs with both my android and MBP: playing music from a browser tab (Songza.com) and then receiving an incoming call on my android correctly mutes the music and outputs the call on the UE Boom - but on ending the call, the music is unmuted correctly but then also starts iTunes. Definitely the UE Boom bluetooth connection triggering iTunes opening and starting to play. Incorrectly. Aug 29, 2014 at 19:21
  • My answer covers this if you follow "the easy way" :) Jan 3, 2017 at 14:38

You didn't indicate if you had checked the Open at Login option in the iTunes Dock icon:

enter image description here


Enable root and remove iTunes.app (like any other directory) permanently, period. That's what I did, and I have 0 regrets.

# rm -rf iTunes.app

I've fixed it. I had implemented all the fixes for this issue that I had found on so many web sites that I was feeling like I'd lucked out.

Turns out that I had a screen saver installed called SoundStream. An audio sensitive screen saver. When this launches after the preset amount of time if iTunes isn't running, it starts it up!

So, if you're having this issue of iTunes starting randomly it may well be your screen saver doing this silently in the background!

  • Oh, no I haven't ... iTunes is still spawning. I'm getting seriously fed up with this app.
    – Jammer
    Feb 27, 2014 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .