0

I installed ZendServer CE. This is my /usr/local/zend/apache2/conf/httpd.conf file: http://codepad.org/vorWrTKb

This is my /etc/hosts file.

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1       localhost
255.255.255.255 broadcasthost
::1             localhost
fe80::1%losd0   localhost

Document root is /Users/anthony/apache/html

If I turn zend server off http:/localhost/ still works. Moreover I have another web-site (php) here /Users/anthony/apache/html/somesite and it also still works on localhost.

At the same time I haven't any virtual hosts in /usr/local/zend/apache2/conf/extra/httpd-vhosts.conf having that documentRoot.

This is my httpd-vhosts.conf file http://codepad.org/qx20aZua

I checked default apache macos service and removed file from /etc/apache2 httpd.conf.

If ZendServer is on:

127.0.0.1 runs /Users/anthony/apache/html/ (correct)

localhost runs /Users/anthony/apache/html/somesite (it shouldn't)

If ZendServer is off:

127.0.0.1 runs /Users/anthony/apache/html/somesite (it shouldn't)

localhost runs /Users/anthony/apache/html/somesite (it shouldn't)

So I cannot understand how localhost works if apache doesn't?

1

The problem was solved.

I run ps aux | grep httpd and got a lot of process. I've killed each process and restarted ZS. Now it's ok)

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .