0

I have remapped one of my top-left keys (`) to the backward-delete key (). However the command-delete shortcut (+) to "move to trash" works only on the original key but not on the remapped key. Any suggestion?

I have remapped the key using Ukelele. I entered "&#x0008"; as the identifier for .

[fyi: purpose is to symmetrize and reduce wrist pain; likewise I remapped caps-lock to enter/return; I'm a customized Dvorak keyboard user; first experience on a Mac]

1

Try using KeyRemap4MacBook instead. Save a file like this as ~/Library/Application Support/KeyRemap4MacBook/private.xml:

<?xml version="1.0"?>
<root>
  <item>
    <name>test</name>
    <identifier>test</identifier>
    <autogen>__KeyToKey__ KeyCode::BACKQUOTE, KeyCode::DELETE</autogen>
  </item>
</root>

Then open the KeyRemap4MacBook application, press the ReloadXML button, and tick the checkbox for the setting.

  • Thanks Lauri, I won't have time to try this for a couple of days as my laptop is getting an upgrade, but will try asap. – PatrickT Feb 23 '14 at 18:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .