0

I FINALLY managed to migrate my triple boot mid-2012 rMBP to a new Haswell model, and was very surprised to see this in Win7:

enter image description here

On the other machine, the "primary hard disk" score was a solid 7.9.

I had some issues getting drivers, etc. installed on this thing, so I guess it's possible that I missed something.

(This is on a loaded 15" rMBP purchased last week. 16GB, 1TB SSD, 2.6GHz.)

Suggestions? Is this typical? Explanations?

Update

I ran Black Magic under OSX and the drive read and write speeds are within spec. Might be a driver issue under Win7.

1

This turned out to be a driver issue, related to having an incorrect version of Bootcamp installed. (This was a result of having moved my Win7 partition from the old machine via Winclone.

Uninstalling Bootcamp (in order to get the new version installed) was a bit of a pain. Whenever I tried to remove the Bootcamp Services app from the "Uninstall a Program" dialog in Win7, I received a message

This version of Bootcamp is not intended for this computer model.

Finally, I used the Microsoft Uninstall Repair Tool, which modified something that let me uninstall the old version of the Bootcamp utilities.

I then ran the new Bootcamp\setup.exe that Bootcamp Assistant downloaded for this machine. Installation proceeded without a hitch, though it took ~10 minutes to complete. I then re-ran the "Windows Experience Index" assessment and got a respectable 7.2 for the SSD:

enter image description here

Surprisingly, still lower than the 7.9 I got on the mid-2012 15" Retina with 768GB SSD.

The WinSat command-line tool provided more insight:

enter image description here

with a read speed of 1181.8 MB/sec, and a write speed of 1019.66 MB/sec. This is roughly equivalent with what BlackMagic reports under OSX.

(Still, I'm wondering if Windows gives speeds > 1GB/sec a 7.2 of 7.9, what on earth do they consider to be a 7.9?)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .