3

I've decided to switch from OS X to Ubuntu. I'm following the documentation on Ubuntu's site for creating a bootable USD Drive.

I converted the ISO to IMG. I ran diskutil list. I inserted my flash drive and ran diskutil list again. My drive is assigned to /dev/disk1. I ran diskutil unmountDisk /dev/disk1. Then I executed sudo dd if=/ubuntu-13.10-desktop-amd64.dmg of=/dev/rdisk1 bs=1m. Then I ran diskutil eject /dev/disk1. Then I restarted, held the alt/option key. The Boot Manager came up, but my flash drive wasn't coming up as an option.

I tried this again just now and it said "The disk you inserted was not readable by this computer." I've never had an issue with this drive before. I restarted anyway, just to see if it worked and I'm still only getting my main hard drive as an option in Boot Manager.

Where do I go from here?

  • I have done the same thing. Firstly, it is easier to create a bootable Ubuntu disk from Ubuntu itself. I do that from an Ubuntu VM. This can be done in VMware Fusion or Virtual Box. Then you need to make sure you download the right Ubuntu ISO. There are several builds available for 13.10 for example. Make sure you download the one that includes support for Intel based Macs. Can you post which Ubuntu image/version you downloaded? – Chad Kemp Feb 22 '14 at 6:38
  • I was able to create a bootable USB stick and I'm receiving an error when trying to load Ubuntu that magic alloc is broken. Apparently, this is a known issue when using Mac Linux USB Loader and I'm trying to find a fix. Any ideas? – WickedJill Feb 25 '14 at 19:11
  • Can you post your setup? Which Mac (13"MacBook Pro Mid 2011 for example), latest firmware updates for the EFI firmware? ... If you have all the latest Mac updates, the answer to that last one is probably 'yes' but it is worth asking. – Chad Kemp Feb 25 '14 at 19:19
  • I'm running a late-2007 MacBook (White) and late-2009 iMac. The MacBook is running Mac OS X Tiger. The iMac is running Mac OS X Mavericks 10.9.2. I can't get all of the info for my MacBook right now, but here's the info for my iMac. Model Identifier: iMac10,1 Boot ROM Version: IM101.00CC.B00 SMC Version (system): 1.52f9 – WickedJill Feb 25 '14 at 20:20
  • I just posted instructions as an Answer. I know creating and firing up a VM is not ideal for you, but it is reliable for creating a bootable USB, and should provide you with alternatives as to how you want to experience Ubuntu before carrying on installing it natively. – Chad Kemp Feb 25 '14 at 20:43
1

I have tested what follows on two different MacBook Pros:

  • 13-inch, Mid 2010 (2.66 GHz Intel Core 2 Duo, 8GB RAM, Nvidia GeForce 320M 256MB)
  • 13-inch, Late 2011 (2.8 GHz Intel Core i7, 16GB RAM, Intel HD Graphics 3000 512MB)

Overview

Create Bootable USB Drive using Startup Disk Creator in Ubuntu itself.
Note: I use Ubuntu daily as a Tomcat Web Server and Java Development environment, and I do so in a Virtual Machine. I understand this is not the most ideal arrangement for someone wishing to create a bootable USB disk to boot a Mac to, but it works, and has proven reliable for me. If you are bent on using Ubuntu natively and want to test it first, a VM is one way to do it, and booting to USB is another. For the full-on experience, installing Ubuntu to your hard-drive (after taking the appropriate measures to back up your harddrive, etc... <disclaimer>I take no responsibility for lost data, etc... </disclaimer>)
There are minor nuances to each of these scenarios:

  1. VM leverages the host OS Networking, so there are no issues with Broadcom drivers
  2. VM will have issues with x/y coordinates of the display (0,0 being the upper left hand corner, for example), meaning hot-corners in Ubuntu will not work properly (for things like auto-hiding the launcher bar)
  3. USB Boot will support your graphics card (most likely) and x/y coordinates will be mapped properly.
  4. USB Boot will not have native WiFi support, so you will have to download Broadcom drivers using a wired connection
    • This is true whether or not you are booting from USB or have Ubuntu installed onto your hard drive

Instructions


I use VMWare Fusion to create my VM's, which is a paid application, though there is a free trial. However, VirtualBox is free to download and use and from what I understand, works quite well also.

That said, I created a Bootable USB Stick using Startup Disk Creator in my Ubuntu 13.10 VM, so I will explain here the steps:

  1. Install Ubuntu 13.10 in Virtual Machine.
    • If this does not quell your curiosity as to whether or not to run Ubuntu natively, then proceed...
  2. Download the Ubuntu 13.10 Mac image from here
    • NOTE: There are 3 links to Ubuntu 13.10 for Desktop. You want to make sure to download the last one... labeled "64-bit Mac (AMD64) desktop image"
  3. Insert a blank USB Key into the Mac, and if given a choice of which system to connect it to (VMWare Fusion recognizes this, and asks what to connect it to, Mac or your VM) choose the VM.
    • This should mount the USB in the VM as a drive (Eg., it should have a mount point in /media)
      Choose to connect to Linux
  4. Open Startup Disk Creator in Ubuntu and choose the target device as the USB drive, and the source as the Ubuntu 13.10 ISO image you downloaded.
    Launch Startup Disk Creator
    Enter Target and Source
  5. Accept the defaults, and click on "Make Startup Disk"
  6. Close out all open applications (including VMs)
  7. Shutdown your Mac.
  8. Insert USB drive into Mac if it is not already
  9. Press Power button to turn on the Mac, and immediately press and hold the Option key.
  10. You should be presented with 2 or 3 boot options.
    • Mac OS Startup Disk
    • Mac OS Repair Partition *may not be present
    • EFI Boot (this should have an Orange USB Drive icon)
  11. Choose the EFI Boot.

NOTE: If you use an Mac with NVidia graphics, you will see a scrambled Boot animation (The Ubuntu logo with the pulsing orange dots). This is due to the fact that Ubuntu defaults to the Open Source drivers for NVidia hardware, and they are not loaded yet. If you choose to install natively, you may want to try the proprietary binary drivers provided by NVidia.

The USB drive you see referenced in that screen shot has Ubuntu 13.10 on it and Boots successfully on the two systems mentioned above.

| improve this answer | |
  • I formatted my USB stick using MS-DOS FAT. Is this the right format? The drive is mounted in Ubuntu using Parallels, but it's not showing up in Startup Disk Creator in the Disk To Use box. – WickedJill Feb 28 '14 at 21:29
  • Does the device show up in Ubuntu at /mnt/media/ ? – Chad Kemp Feb 28 '14 at 22:17
  • It's displaying in Ubuntu as UNKNOWN, which is the current name associated with that USB stick. I'm trying it in VMWare Fusion now. Is there a way that I can just install Ubuntu using Parallels, VirtualBox or VMWare Fusion as the only operating system on my system? – WickedJill Feb 28 '14 at 22:19
  • No. VMWare/Parallels/VirtualBox has to have a Host operating system unless you intend to run something like (the very expensive) Enterprise Virtualization on "bare metal" that is offered by VMWare. If it is mounted properly, you should see the device icon pop up in the Launcher bar on the left inside Ubuntu. Unfortunately you do not have 20 Reputation yet, which means we can't move this discussion to Chat, so if you would like to contact me on Google+ using the email address in my profile, I will be happy to assist you more real-time. – Chad Kemp Feb 28 '14 at 22:27
  • I don't see an e-mail address in your profile. Perhaps you need a certain reputation to see email addresses. I can contact you via your website. – WickedJill Feb 28 '14 at 22:39
0

It sounds like your USB flash drive is not recognized as being bootable?

Try using UNetbootin (http://unetbootin.sourceforge.net/). It should make your USB flash drive bootable.

Download the the version for Mac OS X and simply run it. Follow the prompts and select your USB flash drive, ISO file, or have it download the latest ISO for you. I've used UNetbootin several times under OS X for various Linux distros and it's always worked well.

| improve this answer | |
  • The USB flash drive is booting now, but I'm receiving an error magic alloc is broken. From a brief search online I found that this is a known issue, so I'm digging through forums trying to find a fix. I tried UNetbootin, but it won't let me create a bootable USB flash drive for Mac, only Windows. I've tried several times and it keeps telling me that it was unable to create a bootable drive for Mac and that it'll only work on Windows. I'm wondering if this could have something to do with Mavericks. Any ideas? – WickedJill Feb 25 '14 at 19:10
  • This is a known issue with the software I used. – WickedJill Feb 28 '14 at 21:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .