0

I am new to OS X. Yesterday I set up my email accounts in Mail. It immediately synchronised my emails from my inbox. However, since then I don't get my mails, although I see them through webmail. I heard Mail in Mavericks had problems with IMAP, so I tried to install Thunderbird and Postbox as well with the same result which means I can see the emails I received before yesterday, but none of the new ones. I even tried rebooting but that did not help either.

What is the problem and how can I solve it?

UPDATE: I do not use gmail, my account is hosted by a private provider.

  • Mail in mavericks has some new folders, like Archive!, check if your new mails are there. Also turn off the junk mail filtering in Mail. Also turn off all Rules in Mail. – Ruskes Feb 20 '14 at 16:09
  • Next, go to web gmail and in labels (means folders) check the one you want to show in IMAP. – Ruskes Feb 20 '14 at 16:11
  • Have you tried removing the mail account from Mail.app and adding it again? Does it download the mails up to the same point as before or up to the current time? – onik Feb 21 '14 at 11:13
1

Up front I have to say that it is known factor that mavericks has (had) some issues with IMAP mail providers. There was an upgrade that supposed to address that.

All in all, make sure you have the correct IMAP settings at your provider.

Here is an example for Gmail.

Starting from the settings in your web mail client (ie Gmail)

Go to your web mail (gmail) and in settings, check all folders (Google calls that Labels) you want to see on your computer (show in IMAP).

Just to make sure:

  1. Disable junk mail filtering in your Mail.app on your computer

  2. Disable all Rules in your Mail.app on your computer.

  3. Also take a look for new mails in the Archive folder, which is an equivalent to the Googles "All Mail" folder.

In Mail.app under Window--click on the activity and see it work once you click the Get Mail. It will show you what is going on.

Here are recommended setting for Apple mail from Gmail:

enter image description here

  • I havent added any filtering. It has to be a global OS issue since I got the mails on my windows machine, but all the mail clients show the same emails on my macbook(missing the ones I got today). – David Frank Feb 20 '14 at 22:20
  • Please see my update, I dont use gmail. – David Frank Feb 21 '14 at 10:13
  • Same applies, First check the IMAP settings at your private mail provider, specific to Apple Mail.app, like Google has a recommended settings here: support.google.com/mail/answer/78892?hl=en – Ruskes Feb 21 '14 at 10:43
  • My bad, I was using different IMAP settings on windows, thank you for your detailed answer. – David Frank Feb 21 '14 at 17:25
0

I just switched to Thunderbird as my email client works like Mac Mail should work. Set up time for all 5 of my emails was 20 mins. Everything syncs up across all devices.

-1

I'm a Cox subscriber, and my problem is that I simply can't send emails using Apple Mail. I receive them with no problem, and I have no problem with other operations, such as deletions and filing. If I go to Cox Mail, I have no difficulty sending emails, but because accessing that system is cumbersome--and because I have been creating and filling folders in Apple Mail for several years--I prefer not to switch. What are all you better-informed users planning to do?

  • I should add that I am using a 2009 iMac and don't have the ability to read QR codes. – John Mar 14 '14 at 16:17
  • I should also add that I paid both IYOGI and Cox Tech Solutions to solve the problem. Both companies have tried repeatedly to help but have been able to create only temporary fixes. – John Mar 14 '14 at 16:28
  • 1
    This should be put into a separate question because you haven't provided an answer to this question. – dwightk Mar 14 '14 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .