1

I reinstalled Office 2011 and my Outlook email index stopped updating. I forced a reindex of the entire drive, but the email still wasn't indexing. Stopped by the Genius Bar and they suggested reindexing the drive and repairing permissions (didn't work).

1 Answer 1

3

Finally found the solution to this problem. Outlook provides a custom importer to Spotlight to index email. It is typically found in:

"/Applications/Microsoft Office 2011/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook.mdimporter",

You can use the command /usr/bin/mdimport -L to list all installed importers. When I did that I saw that the importer from the old installation of Outlook was still installed because it was still in the trash can. When I tried to manually import an email using the command usr/bin/mdimport -d2 /[path]/x00_138.olk14Message I saw that it was failing to load the importer from the trash.

Emptying the trash fixed the issue. Wish there was a way to selectively empty the trash without deleting everything.

Once I emptied the trash, I had to force Spotlight to reindex the email folder by adding the /Users/jim/Documents/Microsoft User Data folder to the Privacy tab of Spotlight System Settings, and then removing it again. After spotlight reported the indexing was complete (via the Spotlight dropdown in the upper right) the email was all indexed again.

Hope that helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .