19

I recently tried out CrashPlan on my Macbook, but I decided not to go through with that. However, now that I'm not going to be using CrashPlan after all, I can't figure out how to remove their app from my Mac.

I've tried simply opening up Finder and moving it to Trash but I get the following error when I try that:

an error stating that the operation cannot be performed because I lack the permission to access the item in question

I've also tried deleting it from the command-line using rm -rf CrashPlan.app; even when I run this as root, I still get:

rm: CrashPlan.app/Contents: Operation not permitted
rm: CrashPlan.app: Operation not permitted

I also tried doing this with the GNU version of rm, but I still get an error:

grm: cannot remove ‘CrashPlan.app/Contents’: Operation not permitted

I ran, get info on the CrashPlan app in Finder, and I noticed this:

shows that the crashplan app is locked

However, when I uncheck the locked field and then try to move it to Trash, I still get the same error that I got the first time.

Any ideas?

  • 1
    Have you tried the Standard Uninstall procedure listed here: support.code42.com/CrashPlan/Latest/Getting_Started/… – Scot Feb 19 '14 at 21:45
  • @Deesbek yes, I ran all the rm commands above as root; I'm pretty sure that I even said that I had run them as root. – Alexej Magura Feb 19 '14 at 22:56
  • @AlexejMagura First, you need to disable SIP in recovery mode since the Library directory is protected by default now by macOS. Additionally, the ".app" extension is a wrapper for a directory, and thus the -r flag is needed, and then optionally add the -f flag for force, e.g., rm -rf /Volumes/Macintosh\ HD/Applications/CrashPlan.app and then it would work. Running the uninstaller is unnecessary, and will likely result in old files and directories being left behind. – oemb1905 Jun 26 at 17:48

13 Answers 13

25

Since Crashplan runs with elevated / non-standard permissions for an ordinary app, you will want to:

  1. Reinstall the same or newer version of the software to correct whatever changes non-standard or half-removed. (Free download from http://www.code42.com/store/)
  2. Run the uninstaller that is inside the package contents of the app. (Documented https://support.code42.com/CrashPlan/Latest/Getting_Started/Uninstalling_The_CrashPlan_App)
  3. Optionally delete these two folders if they exist:

    • ~/Library/Application Support/CrashPlan
    • /Library/Application Support/CrashPlan
22

I had this same exact problem and no amount of "uninstalling" would get this pesky application file to DELETE. I even connected this Mac in Thunderbolt Target Mode to another Mac and tried to delete it that way. No go. I was at my wit's end, almost ready for a complete system backup, wipe and re-install.

Fortunately before getting that far, I was able to fix it by removing the "system immutable flag" via Terminal.app, using the "chflags noschg" command.

In the terminal:

cd ~/.Trash/
chflags -R noschg *
rm -fR * # or empty via Finder
  • 2
    This worked for me, but I had to run it as a sudo command: sudo chflags -R noschg * – Alex Roper Jan 23 '15 at 23:23
  • 4
    I used a similar solution - because the uninstall didn't work... sudo chflags noschg /Applications/CrashPlan.app - then used appcleaner. – JorgeLuisBorges May 9 '18 at 10:54
6

CrashPlan app contains an uninstaller built in. You can access the Uninstaller app by following the steps below :

  1. Go to Applications
  2. Control Click on CrashPlan App & choose Show Package Contents
  3. Go to Contents Folder
  4. Locate Uninstall app & double click to run it
  5. Authenticate using Administrator password & wait for it to complete

This whole process should be over it a minute or two.

  • 1
    Simple and effective. Worked like a charm. – Filipe Gonçalves Sep 20 '15 at 15:54
5

Um. I just went to the folder Library/Applicationsupport/CrashPlan and clicked on the uninstaller icon. It uninstalled and it is gone now.

enter image description here

3

A much easier solution is to simply run the included uninstaller on the disk image.

  • Downloading a 50 Mb file is last thing people want to do to get rid of something. The uninstaller is included in the .app > Show Package Contents. – Joel Mellon Sep 14 '14 at 22:39
3

I had the same problem. Fastest solution and worked on both computers was:

(a) Go to http://www.code42.com/store/ (b) Download free version of CrashPlan (c) After clicking to install the pop-up with the application symbol (that you drop into your Applications folder) also has a small trashcan in the bottom right corner. (d) After installation complete click the uninstall trashcan. (e) All old and new crashplan files get removed instantly.

3

I used this and it worked for me:

cd /Applications/CrashPlan.app/Contents/.Uninstall.app/Contents/Resources
sudo chmod u+x uninstall.sh
sudo ./uninstall.sh
2
  1. Open the Finder.
  2. Press Command Shift G
  3. A dialog box appears: Go to the folder.
  4. Paste this text into the dialog box:
    Installed for everyone: /Library/Application Support/CrashPlan/Uninstall.app
    Installed per user: ~/Library/Application Support/CrashPlan/Uninstall.app
  5. Click Go.
  6. Double-click Uninstall.
  7. Follow the prompts to complete the uninstall process.
  8. Remove the following directory from your system:
    Installed for everyone: /Library/Application Support/CrashPlan
    Installed per user: ~/Library/Application Support/CrashPlan
1

There are other reasons for wanting to delete a specific CrashPlan.app

I am in this camp. I have a backup copy of CrashPlan.app this is created by backup software and sometimes I need to delete the backup file and I get into the probem space of the question.

In this case, I am not deleting the primary CrashPlan.app and thus all the advice about uninstall does not apply.

Here is what I had to do:

# Change directory to the particular trashed or non-trash resident CrashPlan.app
cd /Volumes/Mavericks_NonSSD/_CCC SafetyNet/2015-08-05/Applications/CrashPlan.app/

sudo chflags -R noschg *
sudo rm -r Contents/
cd ..
sudo rm -fR CrashPlan.app/
ls -lsaG

All is good now for me....

I actually had to remove the CrashPlan.app from the trashcan and put it back where I deleted it from to get this to work, but it should not be necessary.

0

On OSX the root user is disabled for security reasons. sudo might work, but if not, you can try the following. You need to login as administrator user. On my system, the default user (rxt) is not admin. So I need to do su adminuser, after which the adminuser password is needed. This makes you administrator, but not root. Now you can become root by using sudo -i. In some situations this is different from using sudo plus rm or some other command. If you need more rights, become root by using sudo -i!

0

I couldn't trash Crashplan, either. And when I did option/click, revealing the Package Contents, the uninstaller wouldn't work.

What worked for me was redownloading & reinstalling Crashplan. Then I did the option/click thing, ran the new uninstaller, and this seems to have completely removed Crashplan, including the pre-existing app that I couldn't get to move to the Trash.

  • I followed what harmon said above to redownload, but the install screen now comes with an uninstall option by double clicking a trash can instead of reinstalling the application. – user111014 Jan 25 '15 at 3:20
0

I couldn't remove Crashplan also, tried delete, show contents and run uninstaller no success. Downloaded the app again and you get a new uninstall option. This worked a treat.

0

In terminal copy

sudo rm -R /Applications/CrashPlan.app

enter password, done.

You will still see the app icon but all process are stopped for good; for what I can see.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .