6

I'm trying to enable calendar syncing for my work Gmail account (in System Preferences > Internet Accounts). I already have Mail and Messages enabled on the account with no problems. When I try to enable Calendars, it spins for a while and then gives me an error:

A secure connection couldn't be established.
Click "Continue" to continue creating the account. You can edit the account later in Calendar preferences if necessary.

If I do click Continue, though, it just does the same thing again, so I can never actually enable it.


UPDATE: we recently transferred our email accounts to a new custom domain (we use Google Apps for business, so we don't use @gmail.com), and I'm having this exact issue again. Some additional details:

  • If I try to enable Calendar syncing via Calendar.app (rather than System Preferences > Internet Accounts), I get a different, very generic error:

There was a problem setting up the account.
An unknown error occurred.

  • Using the same exact account info and credentials, I can enable calendar syncing on my iPhone, but my account never appears in Calendar as a group (alongside iCloud, etc.) and therefore I don't see any of its events. So it's still failing, but not giving me an error message like it does on the Mac, for whatever reason.
  • 1
    Open google.com/calendar/syncselect?pli=1 while been logged in to your Google account (on the web) and look if your calenders are enabled for sync. – Ruskes Feb 19 '14 at 15:19
  • Yes, "Contacts' birthdays and events" is checked. – daGUY Feb 19 '14 at 20:34
  • As are "My Calendars" (forgot to mention that). – daGUY Feb 19 '14 at 20:49
  • What it means is you settings for the Internet are not correct for a secure connection (HTTPS), so check those settings. – Ruskes Feb 20 '14 at 15:11
4

After a ton of trial and error, I finally got this working. I don't know what the heck the issue was, but it was a total mess. At one point, I was somehow getting reminders for events in Notification Center even though they weren't appearing on my calendar.

Anyway, I had to:

  • Turn off ALL calendar syncing, including for other accounts (iCloud, Facebook, etc.)
  • Completely delete the problematic account from System Preferences > Internet Accounts
  • Completely delete the contents of ~/Library/Calendars**
  • Log out and back in

Then I set up the problematic account again from scratch (in System Preferences > Internet Accounts) and enabled calendar syncing. This time, it worked like normal, and then I was able to reenable calendar syncing for all my other accounts.

I didn't have to change any settings or anything on Google's end (google.com/calendar).

** Note: I was only able to do this because I don't store any calendars locally. If you have local calendars, deleting the contents of this folder will delete all those events. Just a warning!

  • It worked for me to delete the Gmail account from my Internet Accounts. I did not have to delete the contents of ~/Library/Calendars, nor did I need to log out and back in. – Andrew Hedges Aug 28 '16 at 5:03
1

You could check out this page by Google, explaining about CalDAV used by your iDevice.

In case you have two-step-verification, you need an application-specific password as explained on this Google page. I think this - the two-step-verification - is the issue you're having.

  • 1
    Why would Mail and Message work ? – Ruskes Feb 19 '14 at 15:16
  • I don't seem to have two-step verification since there isn't even a box for it under the Security tab, like it says in Google's instructions. – daGUY Feb 19 '14 at 20:39
  • This wont work, actually it didnt allow me to use my app specific password on a mac. – TjerkW Aug 27 '15 at 19:42
1

I had the same problem, some Gmail calendars were synced and some not.

For me the solution was to check if they are marked for sync within Gmail or not.

To that end visit Google Calendar Sync Select and check if your problematic calendar is marked for sync or not.

By default, all of your own calendars and birthdays are enabled to sync. All others are disabled by default.

0

It's really weird, i tried all of these methods, but it did not help me. I continue search, and find funny answer https://discussions.apple.com/message/26990123#26990123 And it's work! I delete google account from the Internet Accounts in System Preferences, doing relogin, connect to different wifi connection, and setup google account again. And it works, сalendar successfully synchronized.

0

After after trying everything. What worked me was this:

  1. Delete my account from Internet Accounts
  2. Add my account but do not check calendar
  3. From iCalendar add a CalDAV with google.com as server
  4. Done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .