0

I have a 3TB hard drive that I removed from a NAS that is only showing as 800MB on my Mac.

Have tried Disk Utility (and terminal diskutil) but the hard drive keeps showing at the wrong size.

diskutil:

Screen grab from diskutil

Disk Utility (Debug -> Show every partition):

Screen Grab Disk Utility

Partition tab:

enter image description here

The disk in question is the one showing as 801.6 / 801.57 GB. It is in fact a 3TB HDD.

I appreciate that this is something to do with Linux and the mac not reading ext2,ext3 etc..

Don't mind losing all the data on the HDD, just cant figure out how to reformat this drive.

Thanks in advance for any help.

EDIT

I believe this could be an issue with the caddy that I am using not supporting HD greater than 2TB.

Will source an alternative caddy to confirm this.

EDIT

This problem was due to the caddy not recognising HDD greater than 2TB. Is a common problem on older hardware.

  • Was this part of a RAID? Have you tried Erase? – Milliways Feb 19 '14 at 11:51
  • Have tried erase, adding partitions, removing partitions and repairing the drive. It was added as JBOD to the NAS. – noelmcg Feb 19 '14 at 12:22
1

Quit Disk Utility. Try this command in the terminal:

defaults write com.apple.DiskUtility DUDebugMenuEnabled 1

Relaunch Disk Utility. Select Show every partion from the now present Debug menu. See if you can find some hidden partitions and remove them!

Show every partition menu item

  • cheers for the help, tried it but no joy! Can now see the EFI and Recovery partitions (so it works) but the HDD is still coming up as 801.57GB with 1 partition. Have placed the HDD back into the NAS and it is coming up as full capacity. Have used the deletion tools in the NAS when removing the drive but it has no effect on its capacity when hooked up to the Mac. – noelmcg Feb 19 '14 at 19:45
  • Have added the screen grab from disk utility to my question. – noelmcg Feb 19 '14 at 19:48
  • I'd be interested to see the "Partition" tab selected from the top menu in that Disk Utility screen grab. Is there any empty space at the bottom of the Partition Layout graphic? – ghoppe Feb 19 '14 at 19:53
  • Checked the partition tab. There was empty space, and I had a little play around but the most I can get is still 801.57 Have added the screen grab to the question. – noelmcg Feb 19 '14 at 20:15
  • @noelmcg Did you check the RAID tab too? It may be you have to delete the raid set for the space to become available. – ghoppe Feb 19 '14 at 20:37
1

This was an issue with the hard drive caddy not recognising a 3TB hard drive. Have since tried a different caddy and my Mac recognises it fine.

Appears to be a quite common problem if the drive shows up as around 801.6 GB in disk utility. A similar problem would arise in Windows with the disk showing up as around 746 GB

0

If you load Disk Utility and select the drive (not any partitions) then the Partition tab you should be able to re-partition the drive. I assume you want a single, so select 1 Partition from Partition Layout

  • Have tried that first, but that didn't solve the problem. The drive only shows up as an 801.6GB drive, with 1 partition. Normally that would work but it doesn't with this HDD with the way it is partitioned / format at the moment. I believe what the problem is is that 1 partition is FAT32 and the rest is Linux but this doesn't get recognised. – noelmcg Feb 19 '14 at 10:50
  • If you select the drive, it is irrelevant whether OS X can read any of the partitions. If the drive is partitioned with MBR then there some limitations about how you can change it. You should post an image of what Disk Utility shows. – Milliways Feb 19 '14 at 11:12
  • Yep, that was how I imagined it would work. It doesnt seem to for this drive. Have added images to the question. – noelmcg Feb 19 '14 at 11:19
0

Maybe your NAS disk was just one of two parts, and your case is a 2 HD enclosure, thats why is a 2Tb HD and one of them is less than 900 Gb.

  • Carlos It was due to the caddy not being able to recognise HDD greater than 2TB. – noelmcg Jun 22 '14 at 8:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .