3

I have an iPhone 5S running iOS 7.0.4. I want to designate some of my contacts as having an iPhone with the iPhone label vs the generic mobile label. I have edited some contacts and have changed their cell phone number to reflect the iPhone label. However, some contacts the iPhone label is simply not present, nor is the custom option. I can not determine why this behavior is manifesting.

3
  • 2
    Are you editing contacts stored on different accounts? – grg Feb 18 '14 at 17:27
  • Are they all in iCloud? – Rob Feb 18 '14 at 17:28
  • Ahh, this seems to be the issue. I have multiple types of accounts. If I shut off everything but "on my phone" and enter the contact there, the iPhone label is exposed. @Robuust, if you post this as an answer I will flag as such. – Mort Feb 18 '14 at 17:34
2

If they are stored locally instead of on iCloud they will not sync. If you can place them in iCloud they will sync correctly.

Uncheck all accounts to find the wrongly placed contacts, happy hunting! (:

0

In iPhone Version 10.3.2, all I have to do, to get the custom labels is go to Settings, Contacts, Default Account and select "On My iPhone" and then I can add Custom Phone Labels.

0

I had the same problem thanks to the Apple tech guys at the Apple store it is solved, Go to settings Click on Contacts Set default account as iCloud, done

1
  • Setting default account to iCloud did not bring custom label back for existing contacts – Paul Rothenberg Apr 18 '18 at 18:46
-1

The custom lable is missing from all contact just because of account save in your iphone like outlook,gmail etc. To solve this problem. Follw the following steps. 1) Go to settings 2) Tab on mail,account,calendars 3) Than tap on your account like outlook and turn off contact label from all account

1
  • ...and this will DELETE all contacts associated with that account – Ramazan Polat Jan 18 '16 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .