4

How do I delete a network from my Mac?

I removed it from network preferences in the advanced pane but it still appears connected in my list.

I also tried looking for it in Keychain Access but it's not there and I'm still connected.

  • After removing it, did you turn off WiFi and/or restart the OS? It could be something stored in the system as well, but let's start with the obvious first step. – bmike Feb 17 '14 at 22:45
  • Opened KeyChain already and removed the records regarding the network? – Rob Mar 13 '14 at 8:52
  • I would recommend using your MacBook (disabling WiFi and removing it from a wired connection of you have one) then remove the networks from System Preferences and Keychain Access.app . Go to your iPhone and turn off iCloud Keychain. Restart your phone and put your MacBook back on the network/internet and let it sync. After a few minutes (5-10) you should be able to turn on your iPhone's iCloud keychain. – Andrew U. Mar 13 '14 at 9:21
  • @AndrewU. Comments are meant to clarify posts and to add remarks. Answers posted as comments will be kind of lost and never get attention. In your case the solution you propose may solve the problem (either for the OP or for some other visitors later on) so please post it as an answer directly. There is no harm in doing so :-) – nohillside Mar 13 '14 at 10:07
4
  1. Disconnect from your current network:

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/V*/A/R*/airport -z
    
  2. Go to System Preferences → Network → Wi-Fi → Advanced… and remove the network from the list of preferred networks.

  • 1
    Doesn't that dialog read from the system keychain for networks with passwords? It's the easiest place to remove the history so +1 for that. – bmike Feb 17 '14 at 22:44
1

I have recently asked a very similar question and got much better answer in comments. Sorry for the duplicate, but I was using completely different keywords to describe the issue, so didn't find this one before.

Have a look at Andrew's answer here link to the topic

I would recommend using your MacBook (disabling WiFi and removing it from a wired connection of you have one) then remove the networks from System Preferences and Keychain Access.app . Go to your iPhone and turn off iCloud Keychain. Restart your phone and put your MacBook back on the network/internet and let it sync. After a few minutes (5-10) you should be able to turn on your iPhone's iCloud keychain.

1

The fact that the network can't be successfully eliminated doesn't appear to have any connection to iCloud, as it happens on my MacBook which is not connected to iCloud.

What's happening is that the WIFI network password is being stored in Keychain Access. Until it is eliminated from there the Mac will keep on connecting even though it has been instructed to forget a WIFI network. I even wiped the WHOLE content of the Library/Preferences folder and it still remembered the network, so that gave me the clue to check Keychain Access. As soon as I removed the netowrk from Keychain Access, and restarted, I got the "none of your preferred networks are available" dialog

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .