1

so I got a really wierd problem on my mac server

I have a user that I thought was a open directory user, but it had the wrong UID. I then tried disconnecting the OD server, and try to login with another OD user. The server then said the user didn't exist. That was good, cause of course it didn't when I had disconnected the OD server. I then try su to the user that had the UID problem. This user it loged in fine. That was really weird, because that indicated that it was a local user, and not a OD user.

I then went to /etc/passwd

no user with that name. I then tried multiple solutions to get a list of all users on the system. The user did not appear in any of the lists.

I then found a script:

#!/bin/bash
if id -u $1 >/dev/null 2>&1; then
    echo "user exists"
else
    echo "user does not exist"
fi

this script found the user, and said that the user exist, which it should because I'm able to log in as that user.

then I found another script from this link: https://superuser.com/questions/180144/how-can-i-delete-a-mac-os-x-snow-leopard-user-account-from-command-line

that was suppose to delete a specified user. That script says that the user do not exist.

So the user exists in the system, but it isn't.

Can anyone figure this out, because it's bugging up the whole user system?

my os is OSX 10.6.8

thanks

EDIT: for additional info, look at my post on the official apple forum: https://discussions.apple.com/message/24915477#24915477

  • What was the users's UID – Mark Feb 17 '14 at 13:00
  • What is your end goal? Can you image what you have and learn on it later and just restore the server from a backup before the changes made things more confusing? – bmike Feb 17 '14 at 16:15
  • The user id is 1000. It's supposed to be 1050. My end goal is making the server read the OD user, and not this weird user. restoring might bemy last resort, but I am unaware of exactly when the problem started. – Tomas Feb 18 '14 at 7:47

You must log in to answer this question.

Browse other questions tagged .