0

Whenever I type "foo" it gets replaced by "bar". It is working system wide. I can see this behavior in Chrome, TextEdit and other apps. Even partial text like "Somefoo" gets converted to "Somebar". After initial search, I tried changing settings in "Language & Text". I can't find any entry for "foo" or "bar" in it. I tried disabling substitution. It didn't work. I tried "Restore Defaults". It didn't work. I even tried adding rule like "foo" to be replaced by "qux". It doesn't honor this rule and "foo" still gets replaced by "bar". I don't know what else I can try. How can I reset this substitution? Is their any system file or something which I look where these rules are written so I can change it?

I'm using Mac OS X 10.8.4.

Thanks!

  • This previous answer may help... apple.stackexchange.com/questions/104548/… – mkaz Feb 17 '14 at 10:42
  • @mkaz Found ~/Library/Spelling/LocalDictionary but it doesn't contain "foo". I'm not sure if this dictionary is used system wide. e.g. If I type "foo" in Chrome address bar, even that gets transformed. :( – Ankush Feb 18 '14 at 5:46
  • Have you tried Safe Mode? – sayzlim Feb 19 '14 at 11:19
  • How did you initially create the substitution? – dangerousdave Feb 19 '14 at 16:54
  • @dangerousdave Don't remember. I was following some blog sometime back to add a currency symbol in Language and Text. But I removed that entry, this issue still persists. – Ankush Feb 20 '14 at 9:09
3
+50

Try running these commands:

defaults delete -g NSUserReplacementItems
defaults delete -g NSUserDictionaryReplacementItems

Then quit and reopen some application and test if it worked.

NSUserDictionaryReplacementItems is used in 10.9 and NSUserReplacementItems is used in 10.8 and earlier.

  • This didn't work. Tried with TextEdit. :( – Ankush Feb 20 '14 at 9:10
  • 2
    You should login again to flush caches. – Eir Nym Feb 22 '14 at 17:21
  • After above command just now did a restart. It worked. Thanks @EirNym – Ankush Feb 27 '14 at 9:10
0

The best I can suggest is running a recursive grep overnight.

Something like:

grep "bar" * -ri

might provide a clue as to what is happening. This may return a lot of results so pipe the results to a file for examination later, and start your search in folders known to be associated with this functionality such as the ones mentioned above.

I realise this is a far from ideal solution.

-1

Had this with my Mac sometimes. First of all, make sure you have the latest OS version, which would be mavericks. Then download all the updates. Zap pram and smc. Delete cache files with cleanmymac 2 or some vile app you prefer.

This fixes the issue, at least for me.

-1

Safari: In any editable text box, right click and do you go to Spelling and grammar and spelling check mark while typing.

Mail: a new mail, right click and going to Spelling and grammar / spelling check and mark While typing or before sending. Also a new option, which is the Check grammar with spelling appears.

TextEdit, very similar to Mail

Pages and Keynote: Right click and Spelling / Check spelling as you type.

Activating "check spelling" from any application, active for all, all you have to activate each application is to "check grammar with spelling" although as far is activated twice since that option I've only seen in Mail and TextEdit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .