5

I have an early 2009 iMac (9,1), currently running Mac OS 10.5. Now I want to use it as a media center and install XBMC, which only supports Mac OS 10.6 and upwards. The question arises, which OS version is the one that gets the best performance out of my system.

It is a 24' iMac with a 2.93GHz Core 2 Duo processor and 4 GB of RAM.

Which OS between Snow Leopard and Mavericks will be the smoothest on my system? Has there been some comparison of the performance with different OSs?

2
  • Cannot exactly respond to your question, just sharing my experience here. I run Plex Client & Plex Media Server on a Mini Core Duo 1.83GHz + 2GB RAM which tops at 10.6.8 and have no problems whatsoever. It is attached to a 42" 1080 LG via a DVI-HDMI adapter and wired to an AE ac. I can stream to iPads/Macs in the house no problem/no stutters. Your machine is more capable, I would be surprised if running pre Mavericks gives you any advantage. I would just go for the latest OS. Good Luck
    – cucu8
    Feb 16 '14 at 14:45
  • I used 10.9 on an iMac 8,1 so a slightly earlier machine than yours and it felt more responsive for my workload than 10.6. YMMV. The main driver for me would be that 10.6 is very likely to move out of support soon and you might end up in the same situation. Feb 18 '14 at 10:26
1

I would suggest to use Mac OS X 10.6.

For my iMac 24" I have tested all newer versions (on different volumes), and 10.6 is running as it should be. 10.9 seems to be okay, but sometimes I see the "ball" and it takes more time until I can go on...

But it depends what you want to do and what you like - newer systems offers new features (and for me this is exactly why I stay on 10.6). AutoSave and recent application (documents) after computer (re)start might be keywords...

By the way: I would recommend to install LittleSnitch. This tool enhances the firewall for outgoing messages.

0

I have a late 2009 iMac using 10.6 and it is extremely stable without being slow. If you go to 10.7 or above, I suggest reading this article about upgrading )https://discussions.apple.com/docs/DOC-6271). As you install newer OSX releases, backwards compatibility can change and you should verify that the applications you want to use are still supported under the newer OS.

0

I have a late 2009 MacBook Unibody with a Core 2 Duo 2.4 Ghz chip. It runs Mavericks smoothly.

Consider two things:

  • A lot of software will not run on Snow Leopard. Make sure everything you need is still available for 10.6
  • Apple has no official support schedule, but support for 10.6 will certainly phase out soon and that means you will no longer receive security updates (which is important if your Mac is connected to the internet) Update: There are signs that support has already been dropped for Snow Leopard. via Computerworld

(BTW: If you feel your iMac is too slow, consider replacing the disk with a cheap SSD. That gave my MacBook a huge speed improvement)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .