3

Despite the fact that I have told mission control under 10.8 to spaces when switching applications(to the key window), it does not appear to work. In fact the only time spaces works is when I tell it to switch using keyboard shortcuts. This started happening only once I unchecked show dashboard as space.

The following symptoms also occur: -Checking "show dashboard as space" does not re-enable dashboard -Dragging windows to the side of the screen does not cause spaces to switch -Keyboard shortcuts for mission control do not invoke mission control.

Mac OS 10.8

2

I don't think this is a 10.8 specific issue as I experienced the same thing on 10.9.2 when switching out of an application running full-screen. My suspicion is that somehow the spaces plist files get corrupted.

My problem was fixed by regenerating the ~/Library/Preferences/com.apple.spaces.plist file:

  1. Navigate to your user's Library folder. This folder is hidden by default, but you can get there by holding down the option key when you click the Go menu in Finder and selecting Library.
  2. Open the Preferences folder.
  3. Move com.apple.spaces.plist to the desktop. There might be more than one, so drag them all out.
  4. Log out and log back in.
7

I've seen this intermittently for a few releases now. I fix it by restarting the "Dock" process (which handles Spaces/MissionControl) using this Terminal command:

killall Dock

I don't know how to do that via the regular GUI, sorry. And before you run that command, do killall -s Dock to see the processes which will get killed. If only the one "Dock" process is listed then you're good to go. Hope this helps!

  • 1
    This should be the accepted answer. – Matthew Leingang Feb 8 '17 at 19:50
  • Well this only fixed my issue temporarily, @Troyen 's answer fixed the problem permanently. – awiebe Jul 27 '17 at 1:07
2

I was also having this problem on mavericks (osx 10.9.5). Here's how I solved it:

  1. In Finder, click Go->Go to Folder...
  2. Type: '~/Library/Preferences/' and click Go.
  3. Open the file 'com.apple.dock.plist' using a text editor.
  4. Edit the bottom line to: 'workspaces-auto-swoosh = ":true";'.
  5. Restart.

Cheers!

0

I find the issue sometime appears when I change the connected screens whilst the laptop is in sleep mode. Restarting "Dock" works fine for me.

To restart "Dock" via GUI:

  1. Hit "command + space" to bring up spotlight search.
  2. Type "Activity Monitor" an hit "Enter"
  3. Search for "Dock" in the top-right search field in the Activity Monitor
  4. Double click on "Dock", press "Quit" and confirm "Quit"

"Dock" will be automatically restarted by the system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .