In the "Add Printer" dialog Windows section, there are no printers showing up, even though there are several in the office.

enter image description here

I think this might be because my Mac is not "logged onto" the Windows domain where the printers live, but I can't be certain.

What are some common debugging steps to diagnose why a Mac computer on a Windows network can't browse to a Windows printer?

  • Is this Mac currently connected to any Windows workgroup? If so, is it connected to the workgroup the printer is shared from? – michaelmichael Apr 15 '11 at 15:28
  • It's a domain, not a Workgroup. But anyway... the mac IS connected to a different domain than the one the printer is on via mounted smb: drive. – Joel Spolsky Apr 15 '11 at 15:37

Apple's knowledgebase article on troubleshooting shared Windows printers specifies that printers on a different subnet won't show up in the Windows dialog of Add Printer. This sounds to be the case for you.

Since you're able to connect to the domain via smb, you should be able to manually add the printer(s). Select the "Advanced" button at the top of the Add Printer dialog from your screenshot.

Select "Windows" from the Type dropdown menu. You can manually enter the printer's smb URL:


or possibly


Select the appropriate driver and click "Add".

You can get the full steps on how to manually add a Windows printer from Apple's knowledgebase here.

  • 2
    Some time since this answer was written, the Advanced button has disappeared from the Add Printer dialog. You can get it back by right clicking the top of the toolbar, clicking Customize Toolbar, and dragging the Advanced gear onto the toolbar. – Evan Krall Aug 10 '16 at 2:56

Below are three articles for trying to fix this, but generally you can just type




in the windows dialog and that should work if you cannot see the printers automatically.

I had problems printing to windows computers at my work and using these articles, so what I did was manually add the printers by IP address.

ip printing dialog for mac os x


One of the first things I usually do (when it applies) is install the Windows Services for UNIX in the machine with the printer attached. It has fixed most of my problems. In fact OS X usually "forgets" or is unable to correctly identify via SMB with the remote printer/computer, even when you have either guest enabled or a specific user saved in your keychain.

Other than that, try manually browsing to see if you have access to the printer in the first place. If you can manually reach it, then you have a discoverability problem (usually fixed by the above steps) or the steps pointed in other answers.

For what is worth, installing those services on XP machines is very simple and it's included with the XP CD.

You don't really mention where is the printer connected (Windows Version) so I can only guess. If your printer is attached to Windows 7, I'd take a look at the other answers before going crazy.


It may be worth checking the port configuration for the printers. I had a similar issue with wireless Macbooks not seeing a windows shared printer.

In the Ports tab under Printer Properties (Windows) there is the option to Configure Port. Changing this from TCP/IP to LPR, and adding lpd://Printer_Name to the Printer/Queue Name box enabled me to see the printer from the MacBook.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .