0

I have a Mac Mini 10.6.8 for which I've used Screen Sharing frequently. This is NOT a headless Mac. A monitor is attached, it is on and it works fine.

Sometime this week I connected as I always do (Finder -> Connect to Server -> vnc://targetmac.mydomain.edu) only to be greeted with a black screen.

Sitting next to the Mini I can verify from my laptop (10.6.8) that screen sharing works. I can type commands on my laptop and they are executed on the Mini. This is simply a display issue. I know that Screen Sharing is turned on, that I have permissions to connect and that it works. I'm just blind.

Interestingly, my laptop's trackpad movements are NOT transmitted to the Mini. Only keystrokes.

I've tried setting the Screen Sharing app on the Mini to run in 32-bit mode (per this Tidbits article). Tried setting the Screen Sharing on my laptop to 32-bit mode. No dice.

I've tried toggling adaptive quality and full quality. I've tried toggling the Screen Sharing service itself. No dice.

I can connect to an identical Mini (bought the same day, running same OS) from my laptop, so I'm pretty sure this isn't my machine. I've verified that someone using another mac has the same results, so it seems unlikely to be something in my preferences related to this particular Mini.

What the heck?

Could this be some weird video card issue that only affects VNC? Seems unlikely. The most obvious explanation is that the bug mentioned in the Tidbits article was reintroduced, but I'd expect to see other machines similarly affected.

Edit: Ahhh, interesting ... ssh only partly works. I can shell in, use cd and ls ... but if I ps the session hangs once the output fills my laptop's terminal window. Similarly, if I attempt to vi a new file, it hangs after vi clears my laptop's terminal window. This may be a subtle networking thing after all.

0

The last edit was the primary clue ... it was not a VNC-only issue, but a intermittent network issue.

We had a small 5-port hub in the room to support three machines off of the one network drop. Once we removed the hub and plugged the machine directly into the drop all was good. The hub had been there, trouble-free, for more than 3 years.

Once again I am reminded to ask myself more questions. An obvious question would have been: Does the target Mini have good connection to the network, outside of VNC/SSH? Is it dropping packets to reliable servers?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .