2

Lately, when I "Enter Time Machine" (like, to recover a lost file), it switches to my home directory. This might have started with Mavericks, or possibly when I set up the current laptop (about, though not exactly, the same time). Is that a new feature with Mavericks? Is it some configuration thing?

Mainly: how do I make it stop? It prevents restoring files in hidden directories.

2

I tested this on Mavericks, but this method has worked as far as I can remember. Make sure "Show Time Machine in menu bar" is checked in Time Machine Preferences. Select the directory you want to go to as a Finder window and make it the active window. Select use "Enter Time Machine" from the menu bar Time Machine (small clock) drop down menu. Time Machine will open to your selected directory ready to restore files. If you start at a "hidden" directory you can restore from there.

  • That's exactly how I do it, and it always worked until recently. Now, that's exactly what's broken: when I do that, the open Finder window navigates to my home directory during the magical amazing screen pyrotechnics of entering TM. – jackr Feb 20 '14 at 0:03
  • I just tried it. OS 10.9.1 ... the active Finder window (which I had selected, not my home directory) was the one seen inside TM. SO ... you must have something abnormal on your machine! – GEdgar Feb 20 '14 at 1:21
0

I used ls -lO to find all the hidden directories, then used chflags nohidden to unhidify them, and now I can get in with TimeMachine (it acts the same as for regular directories).

I fear the next update or Repair Permissions will break this, but I should be able to restore things (if I can remember this trick!)

  • My trick for remembering tricks like that is to write a script (I store all my scripts in ~/bin) with something like fix-hidden-timemachine as the name. – Alan Shutko Feb 20 '14 at 3:24
0

I don't know how to prevent time machine from opening the first window in your user home folder. However, you can use the Go to Folder... Finder shortcut to choose your preferred folder once the star field ui has rendered itself.

  • Command-Shift-G

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .