7

I am running into a strange problem. After a few minutes of using Chrome or Firefox, two finger scrolling on my trackpad stops working on these applications.

Every time I restart these applications two finger scrolling scrolling works again, but then after a few minutes, it stops working. All my other gestures work fine (one, three and four finger movements) except two-finger scrolling.

I have no idea what is causing this. I haven't had this problem before until today.

I am working on the latest version of Mavericks on the latest MacBook Pro.

Any thoughts?

5

A simpler solution that seemed to work for me in Firefox:

open about:config

and then find the properties

browser.gesture.swipe.left
browser.gesture.swipe.right

and set them from Browser:BackOrBackDuplicate and Browser:ForwardOrForwardDuplicate to empty. It's a workaround for a known bug ( https://bugzilla.mozilla.org/show_bug.cgi?id=927702 ).

  • 1
    Note: This doesn't actually fix the problem, it just prevents it in the cost of disabling swipe gestures that triggers this bug. – totymedli Oct 30 '14 at 10:41
2

This is a defect that is caused by trying to use the two finger gesture to swipe between pages. In Chrome/FF it's supposed to go back and forward in the history, but if there is no history, then it will cause an error and prevent any future scrolling via the trackpad.

A reproduction of the issue and a fix can be found in this video on Scroll Not Working Mac OS X Mavericks in Chrome / Firefox (*loud intro)

To fix it, as long as you're not married to two finger page swiping, you can go to System Preferences > Trackpad > and then disable Swipe Between Pages:

trackpad

Quitting out of chrome and restarting will always restart the trackpad.

If you want to leave it broken, but still have the ability to scroll, you can go to System Preferences > General > and Show Scroll Bars always.

general

1

Two-finger scroll stopped working for me after awaking from a low-battery induced hibernate/sleep. I was able to fix the problem by manually going into sleep and then back out of sleep.

0

Go to Apple --> System Preferences --> Accessibility. Choose "Mouse & Trackpad" from the left column, and click on the "Trackpad Options..." button in the right window. Make sure that the box called "Scrolling" is checked. In my case this was not checked and I couldn't use two-finger scrolling in any window or application.

-1

Warning: This may remove much more than you need!

This solution works but first you have to Enable Hidden Folders to be seen (using your preferred method - I recommend Deeper).

From https://discussions.apple.com/thread/5468141?start=30&tstart=0:

Close all applications, if you want, you may do so by pressing cmd + alt + esc and selecting each application and clicking on the "Force Quit".

Then you have to disconnect all external devices (USB, Firewire, etc ...) and any network cables.

Then you have to disable the Wi-Fi connection.

Then must click the Go button, located next to the Finder on the top bar. Click on "Computer".

Then in the window that opens has to click on "Library".

Now you have to locate the folder Preferences> SystemConfiguration and open it.

Then you have to empty the contents of that folder. If you want you can make a copy first on the desktop.

Then you have to restart your Mac and immediately after the black screen reboot must press this key combination: cmd + alt + P + R, and hold them until they hear the "dong" of the start three times in a row. After that you can safely release. And everything should go ok

  • 2
    Warning: This just blatantly resets all of your SystemConfiguration preferences. It might help, but it would help if you would explain which preference specifically is the issue! – jmiserez Apr 2 '16 at 9:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .