3

I noticed in Activity Monitor that the iCloud Photos process is stopping and restarting a few times every minute. The PID is marching up at a pretty regular pace. When a new iCloud Photos process starts up, it uses the CPU for a bit, so I'd like to stop it from running.

screenshot

Is there any way (a defaults setting?) to prevent this process from running? I don't use iCloud in any way and all of the iCloud services are unchecked in the System Preferences.

2
  • I have the same experience - no iPhoto nor Aperture but this process is not only running but taking 99% CPU and 355Mb RAM. Killing it makes no difference.
    – user79137
    May 27, 2014 at 21:04
  • Very odd, might there be any messages in the console app that seem to indicate if there's an iCloud account error?
    – bmike
    May 27, 2014 at 21:41

2 Answers 2

2

I think I've resolved this by installing iPhoto (fortunately I had paid for it before when I wanted to use it before changing my mind), enabling Photo Stream in the iCloud Systems section (without iPhoto I couldn't do this), leave it for a minute then disable Photo Stream. The iCloud Photos process disappeared from Activity Monitor and has stayed away.

It's odd that the preferences could get messed up if you don't want iCloud, but sometimes writing the in-correct settings followed by the correct one clears the bad setting.

1
  • Thanks for this. The iCloud Photos process has disappeared after following these steps. I hope it stays gone!
    – Rag
    May 31, 2014 at 15:16
1

Go to iPhoto → Preferences → Photo Stream and disable Automatic Import.

1
  • I didn't have iPhoto installed at all, and when I installed it Automatic Import was already disabled.
    – Rag
    Feb 18, 2014 at 4:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .