3

I'm trying to use terminal and in every tab I open, when I try to change directory such as

   cd /

I get a beep and am unable to type the character. I am on the same computer and am able to type a slash in this webpage, just not in that bash shell

I don't have any key-remapping software enabled.

How can I type a forward slash , or determine what is preventing me from typing it?

When I type "shift-/" I get a question mark, so I know the basic essence of the key is working.

Copying and pasting a "/" character results in a beep as well

When I connect an external bluetooth keyboard, the same results happen for both keyboards (on the laptop and on the keyboard)

Yes I rebooted.... many times

1

Let's try a few things.

First, make sure "Secure Keyboard Entry" under the Terminal menu does not have an arrow next to it.

Second, go to Terminal > Preferences > Settings > Keyboard and make sure that forward slash is not defined in the list. Under 'Advanced' make sure 'Declare terminal as:' is set to one of the xterm settings, preferably 'xterm-256'. In the same dialog make sure 'Character encoding:' is set to 'Unicode (UTF-8)'.

Go to System Preferences > Keyboard > Shortcuts and make sure that '/' is not set to do anything in 'Services' and 'App Shortcuts'.

Now try it and see if you still have the same problem.

  • I'm going to accept this as an answer, I was in a crisis mode and had to have it ready in hours... so I reinstalled from scratch. Other strange things were happening too, like it wouldn't shutdown, or start up with extensions off (shift key). With extensions off - before it just rebooted - it took at least 3 min before it crashed/rebooted. – goodguys_activate Feb 14 '14 at 20:57
  • I did all of what you mentioned except the Advanced tab, or check the UTF encoding. Will look into that in the future. TY! – goodguys_activate Feb 14 '14 at 20:58
  • Not working for me, I cannot use / in terminal. And also cannot find ~ on any kayboard osx offers me. Also I cannot find application Character viewer that was in last osx versions.. Well Nice macbook but so a lot of stupidities. – Renetik Sep 19 '16 at 19:50
1

Aha, I just solved the same problem in my computer. Find the file .inputrc in your account directory and make sure you have this line: set covert-meta off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .