0

I just bought a new MBP and I copied the iPhoto '10 library of my old iMac to the Pictures folder of my MBP.

Then I opened iPhoto '11, it said that it has to update the library.

To that point it was just fine and I have my compete library in iPhoto '11 on the MBP.

Then I tried to import the iPhoto '11 library in Aperture and that's my problem: Apertures says it can only import libraries from iPhoto of version 7.x or newer.

My iPhoto '11 library is of course version 9.1.1 so I don't understand the problem. It is however true that the library was first build with iPhoto 08 (or 07 I don't really remember).

Do you have an idea were the problem comes from ? Is there a hidden feature of iPhoto allowing to "consolidate" the library (as in iTunes) ?

Aperture error message

1

Not sure if this will solve your problem but it might be a good starting point.

Try rebuilding the iPhoto library. You can do this by holding down the Command and Option keys while opening iPhoto. You will then need to choose the rebuild options. I think it would probably pay to select all of them. iPhoto will then work away for a long time and rebuild the library.

There is an Apple support web page that details this process further. I would normally say that you should keep a backup before making any changes like this but I guess you still have the copy of the library on the old iMac

If the rebuild doesn't help then I'm not really sure what you can do.

  • OK, it seems to work ! – Cedric H. Apr 15 '11 at 13:43
0

You could get this error if your copy of Aperture doesn't have the latest updates.

  • Indeed, I updated Aperture and it works but I don't know if this solved the problem or the other answer (I did both...). But thanks ! – Cedric H. Apr 15 '11 at 13:42
0

As of Aperture 3.3, iPhoto and Aperture can now open the same photo libraries, so no importing is necessary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .