3

For some reason, the last 15 songs or so that I've downloaded won't sync to my iPhone. I've tried:

  • Removing all music by unchecking "Sync Music" (didn't actually remove the music for some reason) and then re-adding it.
  • Putting those 15 songs in a playlist and syncing only those 15 songs.
  • Rebooting the iPhone.
  • Rebooting the computer.

Nothing has worked so far. Has anyone experienced this and found a solution?


Note:

The computer is a Fall 2013 Macbook Pro 13-Inch running OS X 10.9.1 with the latest version of iTunes installed. The iPhone is an iPhone 5S running iOS 7.0.4.

  • Did you officially buy all this music via Apple or is this music from external source? – Rob Feb 13 '14 at 7:49
  • @Robuust - I sometimes import music from other sources into my library, but they sync to my iPhone, and the majority of the songs that aren't syncing are songs I bought. – pasawaya Feb 13 '14 at 19:04
  • Are you syncing over USB or wifi? – daGUY Feb 16 '14 at 1:14
  • @daGUY - Over USB. – pasawaya Feb 16 '14 at 3:11
  • These are always the same songs or it occur with different files? – gattol Feb 17 '14 at 10:43
2

I had this exact same problem and found the answer I was looking for within one of the Apple communities. Simply go into iTunes store and scroll right to the very bottom. There amongst the small print you'll see an option for purchased. Click on there and you will see a list of all songs/albums and you can choose to either download all or individual tracks. Once downloaded they appear in your library as normal. Don't ask me why they don't appear straight away, but this resolves the problem of those not transferring when syncing

1
+50

From my own experience after updating to iOS 7 I've had the same problem. I fixed this by doing a hardware reset

Hold the powerbutton and the homebutton together until the screen turns black and the Apple logo appears on the screen.

After that, I was able to sync my music correctly. Also check if you have the latest iTunes version as Apple might have put a fix for this issue in a new version.

If that does not work, log out from iCloud on your iDevice and log back in. That fixed the issue for some other people around, it might help you out too!

Please also check out This Official Apple Page, as it's filled with 54 pages of this same problem.

1

Are there any music which you didn't purchase using your current Apple ID? Your iTunes should be authorized with the Apple ID the songs are bought. In case you're not sure, connect your iPhone to your PC/MAC, press "Back-up iPhone" (in the summary page of your iPhone) in iTunes. It will show you what is preventing iTunes from syncing your iPhone.

  • All my music (aside from the songs I manually added to iTunes) was purchased through a single account. – pasawaya Feb 21 '14 at 17:21
  • Did you try backing up your iPhone to iTunes see if it works? – Behdad Feb 21 '14 at 19:42
0

I suspect that you have already done this, but are the iTunes & App Store Settings set such that you have selected Music under the Automatic Downloads section of those settings? This enables the device to automatically download purchases which have been added by other devices via iCloud. Perhaps you are looking for an iCloud independent solution, in which case this response will be useless.

  • I've had that setting checked ever since I got the iPhone, but for some reason it's never automatically downloaded my music purchases. – pasawaya Feb 13 '14 at 19:07
0

I had the same problem and think I found the answer (without having to plug the iPhone to a computer). Go to iTunes Store > Music. Scroll right down to the bottom. You'll find a "Purchased" tab. Click on it and then click on "Recent Purchases" and download.

0

I've had the same issues of purchased songs not showing up on all devices and being "greyed-out" in the iTunes store. I found that for some reason the purchases were hidden and I think I've corrected that. Go to your Account Info. Scroll down to see if any of your purchases are "hidden." I found that over 100 albums had been hidden and correcting it was just a simple step of clicking to "unhide" the albums. I hope this helps!

0

I discovered that I had purchased a new PC since my last download and the PC wasn't "authorized" to receive the transferred purchases. Using "account" tab, "authorizing", you can verify your PC and then all purchased music downloaded.

0

I had the same issue and it was so silly. I had bought Songs off of Drake's new album which has explicit content.

And for some reason explicit content was turned off on my iphone for music. By stroke of luck i though of this and it worked.

Check if your music has the [ E ] sign next to it on the store and if so check to see if the explicit content is set to allow on your device. It worked and the songs were on the phone in a second after that...

-1

I've had the same problem and just figured out that I didn't have the "Use Cellular Data" option turned to "ON" under "iTunes & App Store" in Settings. Once I switched it to "ON", all of my "waiting" music immediately started to download. Hope that helps you!

  • 1
    The person asking the question is syncing their music to the phone over USB. Cellular settings should have no impact here. – Ian C. Sep 14 '14 at 23:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .