2

I work with php and postgre, and since the stock php doesn't come with postgre I had to install a different php version.

So I installed php5 from this website: http://php-osx.liip.ch

It's a quick install, just downloaded php5 and its modules and put them in a different directory, now everything works, except the TextMate's "php run".

I couldn't find where TextMate makes the call to the php and I wanna change it, any ideas?

Thanks.

  • Have you tried setting PATH in TextMate > Preferences > Variables to <path to php5>:$PATH or similar (important is that the path to php5 is listed first), for example /usr/local/php5/bin:$PATH? – jaume Feb 13 '14 at 7:42
2

Under preferences, go into variables and update (or create) TM_PHP to point to your desired executable. E.g. I have /opt/local/bin/php because I'm using MacPorts.

0

In my case it was /usr/local/php5/bin/php whereas 'php5' is an alias that points to the liip installation dir /usr/local/php5-5.3.29-20141019-211753. And by the way it solved my textmate line output on syntax checking on osx 10.12. Thanks a lot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .