4

I'm using Audacity and Soundflower to record sound internally on my MacBook Pro. For example I can play a YouTube video and listen to it with head phones, while recording the sound output. All that works fine, the problem comes when I click record in Audacity. It records the sound, but it is adding an echo or reverb which distorts the sound, especially the bass drum in techno music. How do I turn this echo/reverb off?

Btw, if I listen to the music with my headphones, through Audacity, but I don't click record, the sound is great. The problem comes when I begin to record.

  • Is the music too loud? Audacity displays volume bars for both bass and "other" sound. If they go above limit it will cause problems in sound. – Rob Feb 11 '14 at 8:05
  • I don't believe so. I've adjusted the recording volume and it doesn't get rid of the sound. Also, the bars don't appear to be reaching their max. – luca590 Feb 11 '14 at 18:57
  • Is it possible that you have monitoring activated? Monitoring would output what is coming in and therefor an echo would be created. – Kevin Grabher Mar 30 '14 at 23:50
  • how would I check that/turn it off if necessary? – luca590 May 3 '14 at 1:16
  • There's a mic-symbol. When you click it there should be an option called "monitor input" i believe. I'm sorry, I'm not that audacity-savvy. wiki.audacityteam.org/wiki/Recording_levels – Kevin Grabher May 4 '14 at 22:15
1

I had same problem just fixed it, so assuming you are trying to record audio from Sound Card. The echo reverb is cause by the microphone in your comp, go SoundFlowerBed-->Audio Setup--> Then right click SoundflowerChannel(The one you've setup)---> Set as "Use device for sound input". And that way the microphone its trying to listen to doesnt exist in that channel.

0

Go to applications folder double click Soundflowerbed. A flower symbol appears on you top menu bar next to volume, etc. check 'built-in output.' You probably already did the following:

In system preferences (sound) set sound effects for built in speakers, set input and output for soundflower.

In Audacity preferences set input and output to soundflower.

-1

Had the same problem found out if I went to the audio source on Audacity (between the mic and speaker symbol) and changed it from SoundFlower to Built in Output the echo reverb is gone.

  • but I want to record straight off the sound card, which I can't do if the output is Built in Output – luca590 May 3 '14 at 1:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .