0

I am having a very weird error that I cannot find any help on the rest of the internet for. My issue is that I was editing my httpd.conf (in /Private/etc/apache2) so that I could run the web server out of a different directory. After attempting multiple times (and failing) my system started to act strange. I tried to open XAMPP's httpd.conf using Sublime Text 3 but that threw Sublime Text into a crash loop. I then tried to open another program, and it gave me an error saying that it could not write files. I then tried to close Eclipse and it gave me the error that it could not write files. I figured that a reboot would help and rebooted.

After my system booted up I was unable to log into my main user account. It was giving me the error "You are unable to log into the account "asdf" at this time. An error occurred."

I honestly have no idea why it is not working, but here is what I have tried.

  1. Rebooting
  2. Repairing the main SSD (Where I store my system files, it said that all was fine)
  3. Repairing Permissions on the HDD that holds the User Files (it fixed a ton of applications that were set to different permissions. But it did not change any files that I had been editing.
  4. Repairing the main HDD (all was fine...)

I am at a loss, any help would be greatly appreciated as I cannot use my main user account currently.

1

For anyone in the future that might have this issue (who knows...) here is what I did to fix it:

  1. Go into System Preferences and delete your old user account. Leave your home folder. DO NOT ERASE IT.
  2. Recreate the user.
  3. Right click on the user and select "Advanced Options"
  4. If the home folder location is wrong (if you had it on a different hard drive) change it to the correct place.
  5. Restart your computer.
  6. Fixed!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .