I have MacOs 10.6.6 and a Western Digital external 2.5'' HDD USB 3.0 pre-formatted to NTFS. I try to format the drive do HSF+ with DiskUtility program, but it says: Error: -9944: File system formatter failed

I think I've tried almost all combinations; I tried to set up 1 or 2 partitions with different sizes; journaled or not, but nothing works.

I don't care about the data; I just need the drive to be HFS.

  • Yes, obviously I've tried GUID option before posting
    – tnorgd
    Apr 15 '11 at 10:35

maybe you can try using gparted on a linux livecd?


It's probably a MBR partitioned drive and you hit some obscure error in the mac trying to put a newer file system on a legacy partition scheme.

Have you tried partitioning the drive as GUID Partition Map Scheme under options? I've had luck sometimes changing first to APM and then back to GUID to clear up a corrupt partition record.

If you posted the contents of the disk utility log when attempting this showing a little more information that might help as well. Lastly - what are the current values that Disk Utility reports for Total Capacity as well as Partition Map Scheme?


When you setup the drive partitions, click the option button at the bottom of the disk utility window and change the drive to type GUID. Then proceed to select how many partitions you want and what format you want them in. This should totally wipe the partition information and let you format the drive as HFS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .