I'm filling out a PDF form that doesn't work with Preview so I have to use Adobe Reader (ugh). After I fill out the form, I want to print it to PDF so that it is finalized.

Unfortunately, Adobe disables the Mac print to PDF and tells me I have to save as PDF instead, but if I save as PDF then other people can still edit it. My current annoying solution is to print it to paper and then scan it.

Anyone know a way to circumvent Adobe's disabling of the Mac print to PDF feature?

  • @bmike: The latest of both. OS X 10.6.7 and Reader 10.0.1.
    – minou
    Apr 14, 2011 at 22:28
  • Can you do anything with the PDF button in adobe reader? Sometimes you could mail it or do one of the other options and extract it there. Apr 14, 2011 at 22:33
  • Have you tried locking the PDF with a password? That way you can edit it, but no-one else can.
    – daviewales
    Dec 5, 2012 at 23:29

11 Answers 11


Adobe Reader 10.x does go out of it's way to hide the normal print options from OS X but you can still get to them by clicking on the Printer... button at the bottom of the Adobe Print Dialog and clicking through the warning not to change things behind Adobe's back.

I don't have a form like you mentioned in red, but try setting all the print options in Adobe to make your form appear as desired (with or without stamps, annotations, sticky notes and summaries, etc...) and then get to the Apple print dialog to attempt a print to PDF.

If Adobe isn't preparing the file for print until after you hit print in the Adobe dialog - then your only recourse is faking it out by defining a new virtual printer. That way adobe is forced to send the data to the mac which will then pop it into a plainer PDF file for you with just the data filled out.

I've not resorted to this, but CUPS-PDF and this tip on making it work with Snow Leopard's sandboxing security looks to be promising. I hope you don't have to resort to that hacky of a solution to save paper waste and time.

  • 6
    I've been able to get to the normal OS X print options from Adobe, but after you select print to PDF, Adobe swoops in again and won't let you do it. Arrggh. The virtual printer tip should work but I was hoping for an easier solution.
    – minou
    Apr 15, 2011 at 17:14
  • 1
    This solution does not work (anymore). @user65535's answer below does, though.
    – uvesten
    Feb 23, 2019 at 14:26
  • Thanks @uvesten Are you saying Reader version 10 changed or that you are using a version of Reader that's newer than when I answered this in 2011? Either way, I didn't see the other answer so it now has +1 from me, too. : - )
    – bmike
    Feb 23, 2019 at 14:46
  • 2
    @bmike It seems that in newer versions Adobe has caught on and the "Save as PDF" option now generates an error message saying that "Saving a PDF file when printing is not supported. Instead, choose File > Save." May 19, 2021 at 21:01

I had the same problem and this is what I did after reading this question and answer

  1. I installed a network printer localhost, I chose HP Laserjet Series PCL 4/5 as the driver
  2. Print a document from adobe reader
  3. Open Terminal.app and type the following:

    sudo -s
    cd /private/var/spool/cups
    ls -lh
    Total 1048  
    -rw------- 1 root _lp 1.6K Jan 18 16:24 c00001  
    -rw------- 1 root _lp 1.7K Jan 18 16:40 c00002  
    Drwxrwx--- 10 root _lp 340B Jan 18 16:40 cache  
    -rw-r----- 1 root _lp 259K Jan 18 16:23 d00001-001  
    -rw-r----- 1 root _lp 254K Jan 18 16:39 d00002-001  
    Drwxrwx--T 3 root _lp 102B Jan 18 16:39 tmp

Looking at the timestamp and size, easy to see that d00001-001 and d00002-001 are the postscript files I just printed from Adobe Reader.

  1. pstopdf d00002-001

And you have a d00002-001.pdf file, Change the owner of this file then move this file out to desktop (replace username with your actual username)

  1. chgrp username d00002-001.pdf

  2. mv d00002-001.pdf ~username/Desktop

And there you have it, without having to install any thirdparty pkg or drivers. You can remove the documents from the print queue manually.

just tested on osx 10.11.1 el capitan

  • 1
    On macOS Sierra and Adobe Reader DC 2017, I found the spooled file was already a PDF! I added the PDF extension and moved it out of the queue. Sep 28, 2017 at 12:27
  • Excellent! Works perfectly on Mojave 10.14.3. Note that you don't need the pstopdf step, you can just add the .ps externsion and open the document in Preview, it will convert the file to .pdf automagically.
    – uvesten
    Feb 22, 2019 at 8:03
  • Wonderful, thanks! It worked with mac os 10.12.6, I got a postscript file. Crazy to see how Adobe tries very hard to prevent exporting into a flattened PDF...
    – Ant
    Jun 3, 2019 at 17:48
  • I just printed to my regular printer and paused the job imediatelly, so I was able to skip step 1
    – Adriel Jr
    Feb 17, 2020 at 3:56
  • Worked with a paused printer. Mar 29, 2021 at 4:47

I ended up using PDF Writer. It works perfectly by emulating a printer.

You do have to go ahead and add PDF Writer as a new printer with Preview first.

  • 2
    Didn't work for me on OS X El Capitan... The PDF it created was empty and Preview couldn't open it.
    – Josh Brown
    Nov 18, 2015 at 14:56
  • 1
    Use the other PDFWriter below, this one no longer works on 10.11 and above
    – WayToDoor
    Jan 26, 2022 at 17:27
  • PDF Writer does not work anymore. Use this instead github.com/rodyager/RWTS-PDFwriter
    – sunapi386
    Mar 2 at 22:48

I found the easiest solution was to take one of my existing printers (a Brother HL-2270DW), and pause it (from Printers and Scanners ... Open Print Queue). Then, print to this printer from Adobe Reader, but since it is paused, it will not print yet, and just queue it up. Once that is done, you can follow similar steps as user65535 above, and grab the raw printer files from /var/spool/cups. The files are named d* and can be either PDF or PS format. If they are PDF, you can open them in Preview directly. If they are PS, then Preview will convert it to a PDF file, and then view it - you can then save this PDF.

With these steps, I was able to fill out a form in Acrobat Reader, and then create a PDF that prints properly on my Mac. I didn't have to install any extra 3rd party software. If you still have problems, using "Print to image" in Adobe Acrobat will force it to rasterize the printer output.


As an alternative if you cannot get reader working, the process of printing and scanning your document seems laborious, have you thought of just a screenshot of the document? This should be digitally exactly the same, and you could even open it in preview and "Print to PDF" as you wanted. This would also be not editable in the fashion you said.

  • Thanks for the suggestion, but that won't work. Adobe highlights the form fields in red so it will look different. Also, I think the resolution would be too low.
    – minou
    Apr 14, 2011 at 23:01
  • Can you save it into any other intermediary format? Apr 14, 2011 at 23:35
  • I have the option to save as PDF (editable) and txt.
    – minou
    Apr 15, 2011 at 0:05
  • 2
    Once it's saved as an editable pdf w/txt, can that version be opened in Preview to be printed as a PDF?
    – bg2011
    Nov 22, 2011 at 14:51
  • this is what I ended up doing. Current version of reader has the option of disabling the highlighting, so it looks similar to what you get if you print to pdf using PDFWriter.
    – ivotron
    Jan 7, 2016 at 21:56

I am not sure if this will work for all of the PDF files, but I was having the same issue when printing today. I looked up several solutions and everything seems overly complex. Solutions being download this PDF writer program, or update your adobe version... ext....

I went to the PDF file and clicked print, when the print window showed up I went to the Advanced Printer Settings, it had two options to check mark or un check mark. I check marked the 'print file as image' option and it printed. It took a bit for the printer to start but I worked, everything came out in the correct resolution and none of the colors/text fields were changed.

I am sure this won't solve everyone's problem but hopefully it give you another option to try!

  • Yeah, this didn't work for me. It just printed on the paper printer.
    – jonnybot
    Apr 26, 2018 at 17:54

Try the open-source "virtual PDF printer" RWTS PDFwriter by Rod Yager. It's made for OS X 10.11 El Capitan, so no worries about sandbox/security issued.

After the easy installation you'll get a new "printer" called PDFwriter which works like a charm from Adobe Acrobat Reader. The "printed" PDF files always end up in the "Shared" folder; check /Users/Shared/PDFwriter and the subfolder named after your user.

  • 1
    This works on Monterey too!
    – WayToDoor
    Jan 26, 2022 at 17:26

OK, just throwing another horribly convoluted solution onto the pile. I've found that Amazon's Send to Kindle for Mac works for converting these PDFs. I happened to have it installed already (so preferable to installing three extra flaky PDF printer drivers which may or may not work in my case), and it worked fine. The difficult was that getting a standalone PDF was needlessly complex. You can't download a PDF from your Kindle "Manage your content" page on Amazon (AFAICT), so you have to send it to a third-party device.

PDF Documents, including those from the "Send to Kindle" virtual printer, can be sent to a physical Kindle, or an iOS device's Kindle app, but not, inexplicably, a desktop Kindle app, and also possibly not even an Android device (!). So I had to send to my iPhone. Once it's on your iOS device (or maybe a hardware Kindle, I'm not sure), you can download the document, and then use the "Share" link to email it to yourself. Simple!

Basically the steps I used were:

  1. Print to the "Send to Kindle" printer
  2. Make sure to select "Archive Document in my Kindle Library"
  3. Browse to the "Manage your Content" page on Amazon, and wait for the new document to appear in the "Docs" listing
  4. Deliver the document to your handy iOS device
  5. Open the iOS device and click the share link
  6. Email it to yourself

(You might be able to send directly to your iOS device from Send to Kindle.app and avoid step 3 – I couldn't get that to work, but I don't know whether that was significant)

  • Why would anyone want to print to pdf (save as pdf) a doc that is already PDF (in Adobe)
    – Ruskes
    Dec 23, 2014 at 1:26
  • Some PDFs (especially forms) can be opened in Adobe but not in other PDF-readers (such as Preview.app, or iOS PDF readers). But in most cases, you're right - it's fairly useless, which may be why Adobe has gone to such extraordinary lengths to disable the standard "Print to PDF" feature which you can use in every other OS X app (including, I should note, when you have a PDF open in Preview, so Apple hasn't felt a need to protect us from ourselves in the same way). Less charitably, it could be a way to force everyone to keep using their software. Dec 29, 2014 at 4:08

I just encountered this same problem in Jan 2015, using OS X Yosemite (10.10.2) and Adobe Reader XI (11.0.10). My experience confirmed what bmike said in the accepted answer:

If Adobe isn't preparing the file for print until after you hit print in the Adobe dialog - then your only recourse is faking it out by defining a new virtual printer."

I installed PDFwriter and it worked like a charm. Very easy to install; still works perfectly in OS X Yosemite even though the last release was in 2011.


I came across this question because I was facing the same problem in April 2012 using Mac OS X Lion

I found another solution which was to use Print to VipRiser


Hope this helps other users.

  • 2
    After I updated my mac os x to 10.7.4 VipRiser no longer works
    – Kim Stacks
    Jun 4, 2012 at 6:08
  • I've found that VipRiser works, but only for PDFs I could open in Preview anyway, which kind of defeats the purpose. Dec 23, 2014 at 0:02

I ended up using a browser. Microsoft Edge supports Print to PDF perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .