11

I have this problem: I normally have Bluetooth enabled so I can make use of my speaker system and Magic Trackpad on my mid-2012 11" MacBook Air (2.0 GHz i7, 8GB).

However, when it's enabled, Wi-Fi association does not complete well, either on boot or wake from sleep. In my case, the Wi-Fi icon in the menu bar oscillates a bit and generally gives up. Clicking the icon again may or may not show my network; if it does, I can click it and it will usually associate, though occasionally it complains that association failed. This happens on all networks I regularly use—one, a Buffalo AP, the other, a Linksys.

If I turn Bluetooth off, I can associate just as quickly as I ever have with no issues. I generally don't even see it trying to associate; it's done before I'm logged in.

This appears to be a Mavericks problem, as the folks in the linked Apple discussion are speculating. I know I never had it under ML. Unfortunately, I don't know exactly when I started having the issue, but it seems like it became prevalent around the time I bought the Magic Trackpad. This seems odd, though, since the Trackpad is tens of miles away on one of the networks I'm having issues with.

Is there a workaround that would allow me to leave Bluetooth enabled so I can much more easily use my Trackpad?

8

After digging in the aforementioned Apple discussion, I discovered at one point that an Apple technician recommended to one of the participants that they should remove their com.apple.Bluetooth property list. I did so:

$ sudo rm /Library/Preferences/com.apple.Bluetooth.plist 

and rebooted. When the reboot was complete, Wi-Fi was working flawlessly with Bluetooth on. I lost pairings to all my Bluetooth devices except my Magic Trackpad. I added back my speakers and all remains well 24+ hours later.

UPDATE: Adding my portable speaker seems to have been the straw that broke the camel's back. Had to repeat these steps and then leave it unpaired to keep Wi-Fi working.

  • Interesting, I've just fixed this on my rMBP after the mavericks update. But not reconnected my speaker yet, which speaker do you have? – Jammer May 26 '14 at 13:14
  • HMDX JAM (one of the original run, looks like.) – zigg May 27 '14 at 1:03
  • Nope, it didn't do much for me. My problem is with the PS4 controller. As soon as I turn it on the WiFi goes ballistic. bad latency (lost pings) and download speed down to a crawl. – Michele Dall'Agata May 1 '16 at 11:40
0

I've struggled with this problem for 2,5 days (MBPr, magic mouse). My wifi signal dropped on occasion. When I put my MBPr close to the Airport Extreme (so when the wifi signal was very strong), this problem did not occur. Deleting the Bluetooth prefs file made no difference. I found out eventually that Bluetooth interfered with the wifi signal. The solution: use 5Ghz only for your Wifi. Bluetooth uses 2.4 Ghz so no interference anymore. [Airport Utility: wireless: wireless options: click and name your 5GHz network name]

  • This may work for some people, but I still don't have 5GHz Wi-Fi at home—2.4GHz only—and I haven't had this problem in some time. – zigg Jul 22 '15 at 15:56

You must log in to answer this question.

protected by Community Nov 20 '14 at 3:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .