8

I just got a new Mac Pro with OS X 10.9. When I run:

brew doctor

I get the warning:

Warning: You have MacPorts or Fink installed:
/opt/local/bin/port

This can cause trouble. You don't have to uninstall them, but you may want to 
temporarily move them out of the way, e.g.
sudo mv /opt/local ~/macports

I didn't install MacPorts or Fink, why do I get the warning?

  • 3
    The file /opt/local/bin/port is the MacPorts executable, thus it is installed. What happens if you try the commands port version and port list installed? I use both Homebrew and MacPorts and I get the warning but everything works fine for me :) – Joris Vanhecke Feb 10 '14 at 13:00
  • i tried, but there's no port. "zsh: command not found: port" – William Hu Feb 11 '14 at 1:12
  • Try /opt/local/bin/port version etc - /opt/local/bin is not on yours or the default path – Mark Mar 4 '14 at 0:15
6

Note that some 3rd-party packaging tools may sometimes automatically install MacPorts. I recall RVM does that (or at least used to, I don't know the current state), so while you're not aware of actually installing it manually, it might still be there.

If you move /opt/local to a different location that might break whatever pulled in MacPorts in the first place.

  • This is not an answer and should be a comment – Mark Mar 4 '14 at 0:17
  • It is one possible explanation for the question "I didn't install MacPorts or Fink, why do I get the warning?" asked in the original post. Since I do not see any other questions in the original post, I'd argue that this in fact is an answer. Of course, if you disagree and have the appropriate means to do so, feel free to make this a comment. – neverpanic Mar 4 '14 at 0:28
0

The error reports that /opt/local/bin/port exists.

  • If you haven't installed it, the error is shown because the path exists. Move the executable:

    sudo mv /opt/local/bin/port ~/Desktop
    
  • If you have installed it, you can run the command given:

    sudo mv /opt/local ~/macports
    
  • i didn't installed, and "port" doesn't exist. And there's no path "/opt/local/bin/port", it's wired. – William Hu Feb 11 '14 at 1:14
  • Meanwhile there's a 'bin" under '/opt/local', and there are many files like 'perl, openssl' etc. If i move it to '~/macports', won't it effect these executive files? Not very clear about this. – William Hu Feb 11 '14 at 1:28
  • How dod the files get in /opt/local/bin? Yi had to have installed something that did this – Mark Mar 4 '14 at 0:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .